【PAT甲级 - C++题解】1154 Vertex Coloring

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1154 Vertex Coloring (pintia.cn)
🔑中文翻译:顶点着色
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1154 Vertex Coloring

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No
题意

一个合适的顶点着色是指用各种颜色标记图中各个顶点,使得每条边的两个端点的颜色都不相同。

如果一种合适的顶点着色方案使用了一共 k 种不同的颜色,则称其为合适的 k 着色(k-coloring)。

现在,你需要判断给定的着色方案是否是合适的 k 着色方案。

思路
  1. 直接用一个结构体数组 e 来存储每一条边。
  2. 输入每种染色方案后,遍历每一条边,判断是否每一条边都满足两个点的颜色都不相同,只要有一个边出现两点颜色相同,则都不是一个合法的着色方案。
  3. 根据判断结果输出答案,我们可以用一个 set 容器来对颜色进行去重,set 容器会帮我们将相同的值去掉。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;

struct Edge {
    int a, b;
}e[N];

int n, m;
int color[N];

int main()
{
    cin >> n >> m;

    //输入每条边
    for (int i = 0; i < m; i++)    cin >> e[i].a >> e[i].b;

    //开始查询
    int k;
    cin >> k;
    while (k--)
    {
        //输入每种染色方案
        for (int i = 0; i < n; i++)  cin >> color[i];

        //判断每条边的两个点颜色是否都是不同
        bool success = true;
        for (int i = 0; i < m; i++)
            if (color[e[i].a] == color[e[i].b])
            {
                success = false;
                break;
            }

        if (success)
        {
            //可以用set来对颜色进行去重
            unordered_set<int> s;
            for (int i = 0; i < n; i++)  s.insert(color[i]);
            printf("%d-coloring\n", s.size());
        }
        else puts("No");
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值