【PAT甲级 - C++题解】1011 World Cup Betting

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1011 World Cup Betting (pintia.cn)
🔑中文翻译:世界杯投注
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1011 World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31
题意

给定三场比赛的赔率,其中 W 表示胜利,T 表示平局,L 表示失败,需要计算出能够获得的最大利润,获胜者获得的赔率为三个下注结果的赔率的乘积乘以 65% 以后得到的值。

例如,以下是三场比赛的赔率:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

为了获得最大的利润,我们需要在前两场买平局,第三场买胜利。

如果投注 2 元,那么最大利润将是 (4.1×3.1×2.5×65%−1)×2=39.31 元(最多 2 位小数)。

思路

根据题目规则,我们只用在三场比赛当中找出每场赔率最大的那个即可,找出来之后需要记录一下是获胜的赔率还是平局或失败的赔率,最后输出计算出的结果即可,结果保留 2 位小数。

代码
#include<bits/stdc++.h>
using namespace std;

int main()
{
    double bet = 1;
    string res = "";

    //计算最大赔率
    for (int i = 0; i < 3; i++)
    {
        double w, t, l;
        cin >> w >> t >> l;
        double max_num = max(w, max(t, l));
        if (max_num == w)  res += "W ";
        else if (max_num == t)  res += "T ";
        else    res += "L ";
        bet *= max_num;
    }

    //输出投注结果
    printf("%s%.2lf\n", res.c_str(), (bet * 0.65 - 1) * 2);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值