【PAT(甲级)】1011 World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

解题思路:

找出每一行的最大值相乘,再套到题目中给出的公式里算出答案,同时输出W,T,L的情况即可。

易错点:

读题仔细一点这里说明了,赔率是不相同的,所以不用考虑相同情况下的输出。

 

除此之外没有啥易错点的,感觉就是一道水题。可能输出W,T,L的时候可以有点想法啥的,看代码吧。

代码:

#include<bits/stdc++.h>
using namespace std;

double rm(double a,double b,double c){//返回每行中,最大的那个值 
	if(a>b&&a>c) return a;
	if(b>a&&b>c) return b;
	if(c>a&&c>b) return c;
}

int main(){
	double W[3],T[3],L[3];//分别存储每行中W,T,L的信息 
	double max=1;
	for(int i=0;i<3;i++){
		cin>>W[i]>>T[i]>>L[i];
		if(rm(W[i],T[i],L[i])==W[i]){//如果最大的是W,则输出W,并将max乘以此数字。下同 
			cout<<"W"<<" ";
			max*=W[i];
		}
		else if(rm(W[i],T[i],L[i])==T[i]){
			cout<<"T"<<" ";
			max*=T[i];
		}
		else if(rm(W[i],T[i],L[i])==L[i]){
			cout<<"L"<<" ";
			max*=L[i];
		}
	}
	cout<<fixed<<setprecision(2)<<(max*0.65-1)*2;//输出最大获利 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值