【PAT甲级 - C++题解】1042 Shuffling Machine

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1042 Shuffling Machine (pintia.cn)
🔑中文翻译:洗牌机
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1042 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3
题意

现有 54 张牌,初始顺序为:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

现在给定一个洗牌顺序,需要将上述的顺序按给定顺序进行洗牌,例如当前卡牌顺序为 {S3,H5,C1,D13,J2} ,而洗牌顺序为 {4,2,5,3,1} ,则洗牌后的卡牌顺序为 {J2,H5,D13,S3,C1} ,如果再洗一次那么顺序为 {C1,H5,S3,J2,D13}

输入第一行为洗牌的次数 k ,后跟洗牌的顺序数组,输出洗牌 k 次后的卡牌顺序。

思路

思路如下:

  1. 用数组 p 来保存洗牌顺序,用数组 q 来保存洗牌后的结果,需要先初始化数组 q ,将 S1~J2 映射到 1~54 ,洗牌时用数字表示,输出时再映射回字母。
  2. 进行 k 次洗牌,用数组 w 进行备份,方便下一次洗牌使用。
  3. 输出洗牌后的结果,需要将数字再映射回字母。注意,行末不能有空格。
代码
#include<bits/stdc++.h>
using namespace std;

vector<int> p(55), q(55), w(55);

//输出映射后的卡牌
void print(int x)
{
    if (x <= 13)   cout << "S" << x;
    else if (x > 13 && x <= 26)    cout << "H" << x - 13;
    else if (x > 26 && x <= 39)    cout << "C" << x - 26;
    else if (x > 39 && x <= 52)    cout << "D" << x - 39;
    else    cout << 'J' << x - 52;
}

int main()
{
    int k;
    cin >> k;

    //输入打乱顺序
    for (int i = 1; i <= 54; i++)  cin >> p[i];
    //初始化卡牌顺序
    for (int i = 1; i <= 54; i++)  q[i] = i;

    //进行k次洗牌
    while (k--)
    {
        w = q;
        for (int i = 1; i <= 54; i++)  q[p[i]] = w[i];
    }

    //输出洗牌后的顺序
    for (int i = 1; i <= 54; i++)
    {
        print(q[i]);
        if (i != 54)   cout << " ";
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值