PAT甲级真题 1042 Shuffling Machine (20分) C++实现 (简单模拟)

题目

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

思路

有了初始位置a:1、2、3……54,加上置换规则b,就能得到置换后的位置c,规则是c[b[i]] = a[i];

将得到的c作为下次起始位置,即赋值给a,执行n次,即得到最终位置;

根据位置打印牌号,相当于把10进制数字装换成13进制:

cout << " " << cards[(a[i]-1)/13] << (a[i]-1)%13+1;

其中string cards = "SHCDJ";

一开始手工初始化了所有完整牌号的数组,代码比较冗杂,注意使用转换进制的思想。

代码

#include <iostream>
#include <vector>
using namespace std;

int main(){
    //初始序列
    vector<int> a(55);
    for (int i=1; i<=54; i++){
        a[i] = i;
    }
    //洗牌序列
    int n;
    cin >> n;
    vector<int> b(55);
    for (int i=1; i<=54; i++){
        cin >> b[i];
    }
    //洗牌
    for (int i=0; i<n; i++){
        vector<int> c(55);
        for (int j=1; j<=54; j++){
            c[b[j]] = a[j];
        }
        a = c;
    }
    //打印牌号, 13进制 
    string cards = "SHCDJ";
    cout << cards[(a[1]-1)/13] << (a[1]-1)%13+1;
    for (int i=2; i<=54; i++){
        cout << " " << cards[(a[i]-1)/13] << (a[i]-1)%13+1;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值