【PAT甲级 - C++题解】1029 Median

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1029 Median (pintia.cn)
🔑中文翻译:中位数
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13
题意

给定两个非递减序列,需要我们求出这两个序列合并后的中位数,如果元素个数为奇数,则取中间的值为中位数;如果元素个数为偶数,则取中间两个值的左边那个数为中位数。

思路

这道题可以用二路归并算法来做,要用到双指针,具体思路如下:

  1. 先将两个序列分别存入数组 ab
  2. 定义两个指针 ij ,分别指向 ab 的第一个元素,然后对两指针指向的值进行比较,将小的那个存入数组 c 中,并将指针后移一位。注意,如果其中一个数组已经遍历完而另一个数组还有元素没遍历,则直接将该数组元素全都放到 c 数组的尾部。
  3. 输出 c 数组中的中位数,根据题意,中位数下标应该为 (n+m-1)/2
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 200010;
int a[N], b[N], c[2 * N];
int n, m;

int main()
{
    //输入两个数组元素
    scanf("%d", &n);
    for (int i = 0; i < n; i++)    scanf("%d", &a[i]);
    scanf("%d", &m);
    for (int i = 0; i < m; i++)    scanf("%d", &b[i]);

    //合并两个数组
    int k = 0, i = 0, j = 0;
    while (i < n && j < m)
        if (a[i] <= b[j])  c[k++] = a[i++];
        else    c[k++] = b[j++];
    while (i < n)  c[k++] = a[i++];
    while (j < m)  c[k++] = b[j++];

    //打印中位数
    printf("%d\n", c[(n + m - 1) / 2]);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值