POJ2418/openjudge Hardwood species 二叉搜索树

描述
Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States. 

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications. 

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.
输入
Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.
输出
Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.
样例输入
Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow
样例输出
Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483
提示

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.


分析:

这个题目实际上就是一道模拟题,但是由于数据量很大,所以在搜索的时候需要做优化。如果我们采用二叉搜索,虽然节省了搜索的时间,但是插入新节点的时候需要平移等的操作过于麻烦,所以我们采用二叉搜索树,利用字符串作为关键码值,利用STRCMP函数作为比较的评判标准。


下面来看代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <iomanip>
using namespace std;
struct Node {
	char name[35];
	int num;
	Node *left;
	Node *right;
	Node() {
		name[0] = 0;     //在搜索函数中会看到作用
		num = 0;
		left = right = NULL;
	}
};
Node *search(char des[], Node *root) {   //在二叉搜索树中找对应字符串所在节点位置
	Node *tmp = root;
	while(1) {
		if (tmp->name[0] == '\0') {   //仅有根节点才会出现的情况
			strcpy(tmp->name, des);
			return tmp;
		} 
		int k = strcmp(des, tmp->name);
		if (k == 0)           //就是他了!
			return tmp;
		if (k < 0) {          //搜索左支
			if (tmp->left != NULL) {
				tmp = tmp->left;
				return search(des, tmp);   //递归查找
			}
			else {                             //不可能再找到,说明需要新建节点
				tmp->left = new Node;      
				tmp = tmp->left;
				strcpy(tmp->name, des);
				return tmp;
			}
		}
		if (k > 0) {          //搜索右支,类似左支
			if (tmp->right != NULL) {
				tmp = tmp->right;
				return search(des, tmp);
			}
			else {
				tmp->right = new Node;
				tmp = tmp->right;
				strcpy(tmp->name, des);
				return tmp;
			}
		}
	}
}
//中序遍历二叉搜索树,实现按照字母序打印输出
void output(Node *root, int con) {
	if (root->left != NULL)
		dfs(root->left, con);
	double t = 100 * (double)root->num/(double)con;
	cout << root->name << " ";
	cout << setiosflags(ios::fixed) << setprecision(4) << t << endl;
	if (root->right != NULL)
		dfs(root->right, con);
}
int main()
{
	Node *root = new Node();
	Node *tmp;
	char in[35];
	int count = 0;   //总共多少树
	while(gets(in) != NULL) {
		count++;
		tmp = search(in, root);
		tmp->num += 1;
	}
	output(root, count);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值