HDU6103(枚举)



Kirinriki

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 833    Accepted Submission(s): 327


Problem Description
We define the distance of two strings A and B with same length n is
disA,B=i=0n1|AiBn1i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits
T100
0m5000
Each character in the string is lowercase letter,  2|S|5000
|S|20000
 

Output
For each test case output one interge denotes the answer : the maximum length of the substring.
 

Sample Input
      
      
1 5 abcdefedcb
 

Sample Output
      
      
5
Hint
[0, 4] abcde [5, 9] fedcb The distance between them is abs('a' - 'b') + abs('b' - 'c') + abs('c' - 'd') + abs('d' - 'e') + abs('e' - 'f') = 5
 

Source
思路:
枚举每个位置作为分割两个字串的中点,特别注意有奇数与偶数的区别。
#include<cstdio>
#include<iostream>
#include<string.h>
#include<math.h> 
#include<algorithm>
using namespace std;
int m;
char str[5010];
int sum[5010];
int solve(int l)
{
	int ans=0;
	int s=0;
	int i=0,j=0;
	while(1)
	{
		while(i<l&&s+sum[i]<=m)
		{
			s+=sum[i];
			ans=max(ans,i-j+1);
			i++;
		}
		s-=sum[j];
		j++;
		if(j>=l) break;
	}
	return ans;
}
void work(int l)
{
	int ans=0;
		for(int i=0;i<l;i++)
		{
			int c=0;//当以奇数方式分割 
			for(int j=1;j+i<l&&i-j>=0;j++)
			{
				sum[c]=abs(str[j+i]-str[i-j]);
				c++;
			}
			ans=max(ans,solve(c));
		}
		for(int i=0;i<l;i++)
		{
			int c=0;//当以偶数方式分割 
			for(int j=1;j+i-1<l&&i-j>=0;j++)
			{
				sum[c]=abs(str[j+i-1]-str[i-j]);
				c++; 
			}
			ans=max(ans,solve(c));
		}
		printf("%d\n",ans);
} 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int len;
		scanf("%d",&m);
		scanf("%s",str);
		len=strlen(str);
		work(len);
	}
} 


 

Kirinriki

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 833    Accepted Submission(s): 327


Problem Description
We define the distance of two strings A and B with same length n is
disA,B=i=0n1|AiBn1i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits
T100
0m5000
Each character in the string is lowercase letter,  2|S|5000
|S|20000
 

Output
For each test case output one interge denotes the answer : the maximum length of the substring.
 

Sample Input
       
       
1 5 abcdefedcb
 

Sample Output
       
       
5
Hint
[0, 4] abcde [5, 9] fedcb The distance between them is abs('a' - 'b') + abs('b' - 'c') + abs('c' - 'd') + abs('d' - 'e') + abs('e' - 'f') = 5
 

Source
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值