hdu 5938 Four Operations 模拟

Four Operations

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 210    Accepted Submission(s): 74


Problem Description
Little Ruins is a studious boy, recently he learned the four operations!

Now he want to use four operations to generate a number, he takes a string which only contains digits  '1' -  '9', and split it into  5  intervals and add the four operations  '+''-''*' and  '/' in order, then calculate the result(/ used as integer division).

Now please help him to get the largest result.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test contains one line with a string only contains digits  '1'- '9'.

Limits
1T105
5length of string20
 

Output
For every test case, you should output  'Case #x: y', where  x indicates the case number and counts from  1 and  y is the result.
 

Sample Input
  
  
1 12345
 

Sample Output
  
  
Case #1: 1
 

Source


题目大意:给你一串数字,按顺序把‘+’、‘-’、‘*’、‘/’插进去,要求结果最大。


解题思路:把这5个数设为a,b,c,d,e,结果最小,也就是要求c*d/e尽可能小,a+b尽可能大,c和d一定是个位数,然后c分两种情况,要么个位数,要么两位数。
然后a和b其中一个为个位数,以此进行分类讨论,最后取最大的结果就好了。


#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <functional>
#include <cctype>
#include <vector>
#include <cstdlib>
using namespace std;

typedef long long LL;
const LL INF = 0x3f3f3f3f3f3f3f3f;
const int maxn = 20 + 5;
const int maxn2 = 5e4 + 5;
int t, len;
char str[maxn];

LL Calc() {
    char num[maxn];
    LL ans = -INF;

    for (int i = max(2, len - 4); i <= len - 3; ++i) {
        LL add1 = -INF, add2 = -INF;

        for (int j = 1; j < i; ++j) {
            strncpy(num, str + 1, j);
            num[j] = 0;
            LL temp1 = _strtoi64(num, NULL, 10);

            strncpy(num, str + j + 1, i - j);
            num[i - j] = 0;
            LL temp2 = _strtoi64(num, NULL, 10);

            add1 = max(add1, temp1 + temp2);
        }

        LL mul = (str[i + 1] - '0')*(str[i + 2] - '0');

        strncpy(num, str + i + 3, len - i - 2);
        num[len - i - 2] = 0;
        LL div = _strtoi64(num, NULL, 10);

        add2 = max(add2, -mul / div);

        ans = max(ans, add1 + add2);
    }

    return ans;
}

int main() {
#ifdef NIGHT_13
    freopen("in.txt", "r", stdin);
#endif
    std::ios::sync_with_stdio(false);

    int cas = 0;
    scanf("%d", &t);
    while (t--) {
        scanf("%s", str + 1);
        len = strlen(str + 1);
        printf("Case #%d: %I64d\n", ++cas, Calc());
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值