poj1651 区间dp入门

Description
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650

这个题转移比较好转,就是普通的枚举区间就可以
难点在于如何删除
删除的时候找到一个点,那个对于两边来说这个点就是无法逾越的障碍
就可以用哪个这边的区间了
而对于这个点来说左右两边先拆了谁无所谓….
所以先拆左右后拆中间…

看似好像漏掉了一种情况那就是先拆中间的点
实际上并没有
因为在划分区间的时候就已经包含在内了…
比如中点枚举在c的时候,你想先拆c,后拆a到b和q到w。。。
那样不就和你左边的区间是a到c是一个道理了么….
就是这样…
并没有漏掉情况…
这个题做的很迷
没事的时候还需要多回忆

#include<iostream>
#include<cmath>
#include<memory.h>
#include<cstdio>
#include<algorithm>
using namespace std;
int n;
long long dp[101][101];
long long tu[101];
int inf=0x3f3f3f3f;
int main()
{
    while(cin>>n)
    {
        memset(dp,0,sizeof(dp));
        memset(tu,0,sizeof(tu));
        for(int a=1;a<=n;a++)cin>>tu[a];
        for(int a=1;a<=n;a++)
        {
            for(int b=1;b+a<=n-1;b++)
            {
                dp[b][b+a+1]=inf;
                for(int c=b+1;c<=b+a;c++)
                {
                    dp[b][b+a+1]=min(dp[b][b+a+1],dp[b][c]+dp[c][b+a+1]+tu[b]*tu[c]*tu[b+a+1]);
                }
            }
        }
        cout<<dp[1][n]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值