poj-2955 Brackets 区间dp入门

题目链接

poj-2955 Brackets

题目

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10213 Accepted: 5434

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

题意

给出一串由'(' ')' '[' ']'组成的字符串,定义完全匹配的意义。即子串所有的单个字符均能在该子串中找到对应的匹配位置。例:((()))。中间可以穿插,但是要求能对应匹配,例:()()()。求一个串的最长匹配子串。例:)()(,其值为2,只有子串()匹配。现在给出一个字符串,输出最长的匹配子串长度。输入"end"结束。

题解

这个题是区间dp的入门题。个人对于区间dp的理解,精髓在于如何合并区间。更为经典的堆石子问题就能体现这个操作。这个题也完全利用了分区间的思想,状态上我们定义dp[i][j]表示第i个字符到第j个字符的子串,值就是最大的匹配值。那么定义一个k,将字符串分为2个区间,2个区间分别的值加起来就是可能的最大值。所有的k的最大值就是最终答案。也就是说,我们可以得到O(n^3)的算法,枚举i、j获得区间,枚举i < k < j来分区间。

如果开头与结尾2个字符恰好能匹配,那么dp[i][j] = dp[i+1][j-1]+2是错误的。例如:()()()。)()(的值是2,而()()()的值是6,因为这样忽略了原来不匹配的部分有可能跟两端的字符匹配。所以仍然需要划分区间求解。

C++ 代码 32ms

#include<iostream>
#include<vector>
#include<string>
#include<cmath>
#include<algorithm>
#include<map>
#include<utility>
#define TIME std::ios::sync_with_stdio(false)
#define LL long long
#define MAX 110

using namespace std;

int dp[MAX][MAX];

int Max(int a, int b) {
    return a > b ? a : b;
}

int main() {
    TIME;
    string s;
    while (cin >> s) {
        if (s == "end") break;
        int len = s.size();
        memset(dp, 0, sizeof(dp));
        for (int i = len - 1; i > 0; i--) {
            for (int j = i + 1; j <= len; j++) {
                int m = 0;
                if (s[i - 1] == '(' && s[j - 1] == ')' || s[i - 1] == '[' && s[j - 1] == ']') {
                    m = dp[i + 1][j - 1] + 2;
                }
                for (int k = i + 1; k < j; k++) {
                    m = Max(m, dp[i][k] + dp[k][j]);
                }
                dp[i][j] = m;
            }
        }
        cout << dp[1][len] << endl;
    }

    system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值