HDU5012 bfs

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b1.b2,b3,b4,b5,b6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while ai ≠ aj and bi ≠ bj for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, ai ≠ bi). Ddy wants to make the two dices look the same from all directions(which means for all i, ai = bi) only by the following four rotation operations.(Please read the picture for more information)

Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.

Input
There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a1,a2,a3,a4,a5,a6, representing the numbers on dice A.

The second line consists of six integers b1,b2,b3,b4,b5,b6, representing the numbers on dice B.

Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.

Sample Input
1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6

Sample Output
0
3
-1

这就是个bfs
你看这个正方体来回滚动只有四种操作
他最多滚个6次不能再多了…..
所以超过6就break好了
另外这次临时想出了一种以前从来没用过的办法。。
那就是开俩队列…
一个存动作一个存步数…
挺好使的就是差点超内存….

#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
#include<string>
#include<vector>
using namespace std;
struct p
{
    int shang,xia,zuo,you,qian,hou;
};
p you(p yuan)
{
    return {yuan.zuo,yuan.you,yuan.xia,yuan.shang,yuan.qian,yuan.hou};
}
p zuo(p yuan)
{
    return {yuan.you,yuan.zuo,yuan.shang,yuan.xia,yuan.qian,yuan.hou};
}
p qian(p yuan)
{
    return {yuan.qian,yuan.hou,yuan.zuo,yuan.you,yuan.xia,yuan.shang};
}
p hou(p yuan)
{
    return {yuan.hou,yuan.qian,yuan.zuo,yuan.you,yuan.shang,yuan.xia};
}
int main()
{
    p aa,bb;
    while(cin>>aa.shang>>aa.xia>>aa.zuo>>aa.you>>aa.qian>>aa.hou>>bb.shang>>bb.xia>>bb.zuo>>bb.you>>bb.qian>>bb.hou)
    {
        queue<p> qq;
        qq.push(aa);
        queue<int> ji;
        ji.push(0);
        int jiance=-1;
        while(!qq.empty())
        {
            p ou=qq.front();
            qq.pop();
            int oo=ji.front();
            ji.pop();
            if(ou.shang==bb.shang&&ou.xia==bb.xia&&ou.zuo==bb.zuo&&ou.you==bb.you&&ou.qian==bb.qian&&ou.hou==bb.hou)
            {
                jiance=oo;
                break;
            }
            oo++;
            if(oo<8)
            {
                qq.push(zuo(ou));
                qq.push(you(ou));
                qq.push(qian(ou));
                qq.push(hou(ou));
                for(int a=1;a<=4;a++)ji.push(oo);
            }
        }
        if(jiance==-1)cout<<-1<<endl;
        else cout<<jiance<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值