hdu 5012 Dice BFS 2014 ACM/ICPC Asia Regional Xi'an Online

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5012

Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)


Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A.

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
 

Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 

Sample Input
  
  
1 2 3 4 5 6 1 2 3 4 5 6 1 2 3 4 5 6 1 2 5 6 4 3 1 2 3 4 5 6 1 4 2 5 3 6
 

Sample Output
  
  
0 3 -1
 

Source


比赛的时候想复杂了,看了题解,发现真的是个很easy的BFS....T_T

方向数组:

e: 0 1 2 3 4 5

左:3 2 0 1 4 5
右:2 3 1 0 4 5
前:5 4 2 3 0 1
后:4 5 2 3 1 0

代码:

#include <algorithm>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cctype>
#include <cmath>
#include <stack>
#include <queue>
#include <list>
#include <map>
#include <set>

using namespace std;

#define min2(x, y)     min(x, y)
#define max2(x, y)     max(x, y)
#define min3(x, y, z)  min(x, min(y, z))
#define max3(x, y, z)  max3(x, max(y, z))
#define clr(x, y)      memset(x, y, sizeof(x))
#define fr(i,n)        for(int i = 0; i < n; i++)
#define fr1(i,n)       for(int i = 1; i < n; i++)
#define upfr(i,j,n)    for(int i = j; i <= n; i++)
#define dowfr(i,j,n)   for(int i = n; i >= j; i--)
#define scf(n)         scanf("%d",&n)
#define ptf(n)         printf("%d",n)
#define ptfs(s)        printf("%s",s)
#define ptln()         printf("\n")
#define srt(a,n)       sort(a,n)
#define LL long long
#define pi acos(-1.0)
#define inf 1 << 31-1
#define eps 0.00001
#define maxn 6
#define maxm 7

struct node
{
    int arr[maxn];
    int step;
}s,e;

int is_ok(node a, node b)
{
    fr(i,maxn)
    if(a.arr[i] != b.arr[i])
        return 0;
    return 1;
}
int vis[maxm][maxm][maxm][maxm][maxm][maxm];

node turn(node a,int dir)
{
    node b;
    if(dir == 0)
    {
        b.arr[0] = a.arr[3];
        b.arr[1] = a.arr[2];
        b.arr[2] = a.arr[0];
        b.arr[3] = a.arr[1];
        b.arr[4] = a.arr[4];
        b.arr[5] = a.arr[5];
    }
    if(dir == 1)
    {
        b.arr[0] = a.arr[2];
        b.arr[1] = a.arr[3];
        b.arr[2] = a.arr[1];
        b.arr[3] = a.arr[0];
        b.arr[4] = a.arr[4];
        b.arr[5] = a.arr[5];
    }
    if(dir == 2)
    {
        b.arr[0] = a.arr[5];
        b.arr[1] = a.arr[4];
        b.arr[2] = a.arr[2];
        b.arr[3] = a.arr[3];
        b.arr[4] = a.arr[0];
        b.arr[5] = a.arr[1];
    }
    if(dir == 3)
    {
        b.arr[0] = a.arr[4];
        b.arr[1] = a.arr[5];
        b.arr[2] = a.arr[2];
        b.arr[3] = a.arr[3];
        b.arr[4] = a.arr[1];
        b.arr[5] = a.arr[0];
    }
    return b;
}
int  bfs()
{
    clr(vis,0);
    queue <node> q;
    q.push(s);
    vis[s.arr[0]][s.arr[1]][s.arr[2]][s.arr[3]][s.arr[4]][s.arr[5]] = 1;
    node now, next;
    while(!q.empty())
    {
        now = q.front();
        q.pop();
        if(is_ok(e, now))
            return now.step;
        fr(i,4)
        {
            next = turn(now, i);
            if(!vis[next.arr[0]][next.arr[1]][next.arr[2]][next.arr[3]][next.arr[4]][next.arr[5]])
                {
                    next.step = now.step + 1;
                    vis[next.arr[0]][next.arr[1]][next.arr[2]][next.arr[3]][next.arr[4]][next.arr[5]] = 1;
                    q.push(next);
                }
        }
    }
    return -1;
}
int main()
{
    //freopen("in.txt", "r", stdin);
    clr(s.arr, 0);
    clr(e.arr, 0);
    while(scf(s.arr[0])==1)
    {
        fr1(i,6)
        scf(s.arr[i]);
        s.step = 0;
        fr(i,6)
        scf(e.arr[i]);
        ptf(bfs());
        ptln();
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值