HDU4035 递推求期望

Problem Description

When wake up, lxhgww find himself in a huge maze.

The maze consisted by N rooms and tunnels connecting these rooms. Each pair of rooms is connected by one and only one path. Initially, lxhgww is in room 1. Each room has a dangerous trap. When lxhgww step into a room, he has a possibility to be killed and restart from room 1. Every room also has a hidden exit. Each time lxhgww comes to a room, he has chance to find the exit and escape from this maze.

Unfortunately, lxhgww has no idea about the structure of the whole maze. Therefore, he just chooses a tunnel randomly each time. When he is in a room, he has the same possibility to choose any tunnel connecting that room (including the tunnel he used to come to that room).
What is the expect number of tunnels he go through before he find the exit?

Input

First line is an integer T (T ≤ 30), the number of test cases.

At the beginning of each case is an integer N (2 ≤ N ≤ 10000), indicates the number of rooms in this case.

Then N-1 pairs of integers X, Y (1 ≤ X, Y ≤ N, X ≠ Y) are given, indicate there is a tunnel between room X and room Y.

Finally, N pairs of integers Ki and Ei (0 ≤ Ki, Ei ≤ 100, Ki + Ei ≤ 100, K1 = E1 = 0) are given, indicate the percent of the possibility of been killed and exit in the ith room.

Output

For each test case, output one line “Case k: ”. k is the case id, then the expect number of tunnels lxhgww go through before he exit. The answer with relative error less than 0.0001 will get accepted. If it is not possible to escape from the maze, output “impossible”.

Sample Input

3
3
1 2
1 3
0 0
100 0
0 100
3
1 2
2 3
0 0
100 0
0 100
6
1 2
2 3
1 4
4 5
4 6
0 0
20 30
40 30
50 50
70 10
20 60

Sample Output

Case 1: 2.000000
Case 2: impossible
Case 3: 2.895522

这个题他和他爹他祖宗他儿子都有关系直接求拿头也求不出来

但是偶然发现儿子是能求的
那么只和祖宗和爹有关了
祖宗是最后要求的
那也很尴尬
后来发现这个期望的式子的系数是能一一对应的
可以
求出来了。。。
感觉后面甚至可能会碰到矩阵优化的…

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
struct s
{
    double x, y, z;
};
vector<int>tu[100001];
s dp[10001];
int biaoji[10001];
double e[10001], k[10001];
int n;
void dfs(int gen)
{
    biaoji[gen] = 1;
    int jc = 0;
    double xx = 0, yy = 0, zz = 0;
    double m = 0;
    for (int a = 0;a < tu[gen].size();a++)
    {
        if (biaoji[tu[gen][a]] == 1)continue;
        dfs(tu[gen][a]);
        xx += dp[tu[gen][a]].x;
        yy += dp[tu[gen][a]].y;
        zz += dp[tu[gen][a]].z;
        m += 1;
        jc = 1;
    }
    m = tu[gen].size();
    if (!jc)
    {
        dp[gen] = { k[gen],1 - k[gen] - e[gen],1 - k[gen] - e[gen] };
        return;
    }
    double yijianke = 1 - k[gen] - e[gen];
    double fenmu = 1 - ((yijianke*yy) / m);
    dp[gen] = { (k[gen] + yijianke*xx / m) / fenmu,yijianke / (fenmu*m),(yijianke*((zz / m) + 1)) / fenmu };
    return;
}
int main()
{
    int T;
    cin >> T;
    int u = 0;
    while (T--)
    {
        cin >> n;
        memset(dp, 0, sizeof(dp));
        memset(biaoji, 0, sizeof(biaoji));
        for (int a = 1;a <= n;a++)tu[a].clear();
        int q, w;
        for (int a = 1;a <= n - 1;a++)
        {
            scanf("%d%d", &q, &w);
            tu[q].push_back(w);
            tu[w].push_back(q);
        }
        int kk, ee;
        for (int a = 1;a <= n;a++)
        {
            scanf("%d%d", &kk, &ee);
            k[a] = kk / 100.0;
            e[a] = ee / 100.0;
        }
        dfs(1);
        printf("Case %d: ", ++u);
        if (fabs(dp[1].x-1)<=1e-9)cout << "impossible" << endl;
        else printf("%.8lf\n", (dp[1].z) / (1 - dp[1].x));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值