lightoj 1284(59/600)

You are given a 3D grid, which has dimensions X, Y and Z. Each of the X x Y x Z cells contains a light. Initially all lights are off. You will have K turns. In each of the K turns,

  1. You select a cell A randomly from the grid,
  2. You select a cell B randomly from the grid and
  3. Toggle the states of all the bulbs bounded by cell A and cell B, i.e. make all the ON lights OFF and make all the OFF lights ON which are bounded by A and B. To be clear, consider cell A is (x1, y1, z1) and cell B is (x2, y2, z2). Then you have to toggle all the bulbs in grid cell (x, y, z) where min(x1, x2) ≤ x ≤ max(x1, x2), min(y1, y2) ≤ y ≤ max(y1, y2) and min(z1, z2) ≤ z ≤ max(z1, z2).

Your task is to find the expected number of lights to be ON after K turns.

Input
Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case starts with a line containing four integers X, Y, Z (1 ≤ X, Y, Z ≤ 100) and K (0 ≤ K ≤ 10000).

Output
For each case, print the case number and the expected number of lights that are ON after K turns. Errors less than 10-6 will be ignored.

Sample Input
5
1 2 3 5
1 1 1 1
1 2 3 0
2 3 4 1
2 3 4 2
Sample Output
Case 1: 2.9998713992
Case 2: 1
Case 3: 0
Case 4: 6.375
Case 5: 9.09765625

这个题首先是要分开三维
然后是组合计数问题
任选两个点n*n
问能覆盖到a点的情况有几种
这个比较好想
用所有的总情况减掉不可能覆盖的剩下的就是可能出现的情况了

然后是用牛顿那个啥玩意定理
组合数改成快速幂

很舒服

#include<bits/stdc++.h>
using namespace std;
double p[111][111];
double ksm(double ds,int zs)
{
    double fs=1;
    while(zs)
    {
        if(zs&1)fs*=ds;
        zs>>=1;
        ds*=ds;
    }
    return fs;
}
int main()
{
    for(int a=1;a<=105;a++)
    {
        for(int b=1;b<=a;b++)
        {
            p[a][b]=(a*a-(b-1)*(b-1)-(a-b)*(a-b));
        }
    }
    int T;
    cin>>T;
    int u=0;
    while(T--)
    {
        int x,y,z,k;
        cin>>x>>y>>z>>k;
        double jg=0;
        for(int a=1;a<=x;a++)
        {
            for(int b=1;b<=y;b++)
            {
                for(int c=1;c<=z;c++)
                {
                    long long wewe=x*x;
                    wewe*=y*y;
                    wewe*=z*z;
                    double sdsd=wewe;
                    double pp=p[x][a]*p[y][b]*p[z][c]/(sdsd*1.0);
                    jg+=(1-ksm(1-2*pp,k))/2.0;
                }
            }
        }
        printf("Case %d: %.10f\n",++u,jg);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值