HDU 1237 双栈模拟

3 篇文章 0 订阅
3 篇文章 0 订阅

http://acm.split.hdu.edu.cn/showproblem.php?pid=1237
Problem Description

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output

3.00
13.36

#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
#include<stack>
int main()
{
    char str[222];
    while (gets(str),strcmp(str,"0"))
    {
        int len=strlen(str);
        stack<double>S,SS;
        stack<char>s,ss;
        for (int i=0;i<len;i++)
        {
            if (str[i]==' ')
                continue;
            else if (str[i]=='*'||str[i]=='/')
            {
                double x=S.top();
                S.pop();
                int j;
                double y=0;
                for (j=i+2;j<len;j++)
                {
                    if (str[j]!=' ')
                    {
                        y=y*10+str[j]-'0';
                    }else
                    break;
                }
                if (str[i]=='*')
                    S.push(x*y);
                else
                    S.push(x/y);
                i=j;
            }
            else if (str[i]=='+'||str[i]=='-')
                s.push(str[i]);
            else
            {
                int j;
                double x;
                x=0;
                for (j=i;j<len;j++)
                {
                    if (str[j]!=' ')
                        x=x*10+str[j]-'0';
                    else
                        break;
                }
                S.push(x);
                i=j;
            }
        }
        while(!S.empty())
        {
            double x=S.top();
            SS.push(x);
            S.pop();
        }
        while(!s.empty())
        {
            char ch=s.top();
            ss.push(ch);
            s.pop();
        }
        while(!SS.empty()&&!ss.empty())
        {
            double x1=SS.top();
            SS.pop();
            double x2=SS.top();
            SS.pop();
            char ch=ss.top();
            ss.pop();
            if(ch=='+'){
                SS.push(x1+x2);
            }else
                SS.push(x1-x2);
        }
        printf("%.2lf\n",SS.top());
    }
    return 0;
}

顺便在HDU Discuss区看到了不用栈的做法 鸣谢他的代码:


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    double num[205];
    int i;
    double s;
    char f;
    double sum;
    while(cin>>s)
    {
        memset(num,'\0',sizeof(num));
        num[0]=s;
        i=0;
        f=getchar();
        if(f=='\n'&&s==0)break;
        while(1)
        {
            cin>>f>>s;
            if(f=='*')num[i]*=s;
            else if(f=='/')num[i]/=s;
            else if(f=='+')num[++i]=s;
            else
            {
                num[++i]=-s;
            }
            if(getchar()=='\n')break;
        }
        sum=0;
        for(i;i>=0;i--)
            sum+=num[i];
        printf("%.2lf\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值