HDU 1010 Tempter of the Bone(DFS+剪枝)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 87753    Accepted Submission(s): 23880


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 


题目大意是不能回头,问狗是否能在规定的时刻到达门处。不难想到用dfs,但是普通的dfs会超时,所以就要剪枝。这一题最重要的一个剪枝就是判断曼哈顿距离与规定时刻的奇偶性是否相同,如果不同则一定不能在规定时刻到达。因为狗如果能在规定时刻之前到达大门处一定需要先离开离开再进入最短路,所以差值一定是偶数。另外还要注意题目输入的t之后可能会多一个空格,用getchar()的要注意。

#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN=10;
int n,m,t,vis[MAXN][MAXN],s[2],e[2],flag,dir1[4]= {1,-1,0,0},dir2[4]= {0,0,1,-1};
char map[MAXN][MAXN];

bool over(int x,int y)
{
    if(x<1||x>n||y<1||y>m)
        return true;
    return false;
}

void dfs(int x,int y,int time)
{
    if(flag||time>t||over(x,y))
        return ;
    if(time==t)
    {
        if(map[x][y]=='D')
            flag=1;
        return ;
    }

    for(int i=0; i<4; i++)
    {
        if(flag)
            return ;
        int xx=x+dir1[i];
        int yy=y+dir2[i];
        if(!vis[xx][yy]&&!over(xx,yy)&&map[xx][yy]!='X')
        {
            vis[xx][yy]=1;
            dfs(xx,yy,time+1);
            vis[xx][yy]=0;
        }
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
char ttt[5];
    while(scanf("%d%d%d",&n,&m,&t)!=EOF)//t后可能多出一个空格,如4[ ]4[ ]8[ ]
    {
        if(n==0&&m==0&&t==0)
            break;
        memset(vis,0,sizeof(vis));
        memset(map,0,sizeof(map));
        flag=0;
        int cnt=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%s",map[i]+1);
            for(int j=1; j<=m; j++)
            {
                if(map[i][j]=='S')
                {
                    vis[i][j]=1;
                    s[0]=i;
                    s[1]=j;
                }
                if(map[i][j]=='D')
                {
                    e[0]=i;
                    e[1]=j;
                }
                if(map[i][j]=='.')
                    cnt++;
            }
        }
        if(cnt<t-1||(abs(s[0]-e[0])+abs(s[1]-e[1]))>t||(abs(s[0]-e[0])+abs(s[1]-e[1]))%2!=t%2)//第3个条件是判断曼哈顿距离与规定时刻的奇偶性是否相同,若不同,则一定无法在规定时刻到达大门处
        {
            printf("NO\n");
            continue;
        }
        dfs(s[0],s[1],0);
        printf("%s\n",flag?"YES":"NO");
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值