字典树基本模板——统计难题

    通过一棵数来存储每一个位置的字符的个数以及该字符是否出现。

主要代码

Trie *root = NULL;
void Insert(char *word)
{
    Trie *cur = root;
    int i,len;
    len = strlen(word);
    for(i = 0; i < len; i++)
    {
        int id = word[i]-'a';
        if(cur->child[id] == NULL)
            cur->child[id] = new Trie;
        else
            cur->child[id]->num++;
        cur = cur->child[id];
    }
}

统计难题    点击此处

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀). 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 

注意:本题只有一组测试数据,处理到文件结束. 

Output

对于每个提问,给出以该字符串为前缀的单词的数量. 

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output

2
3
1
0
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 26;
const int M = 11;
char s[M];
struct Trie
{
    int num;
    Trie *child[maxn];
    Trie()
    {
        for(int i = 0; i < maxn; i++)
            child[i] = NULL;
        num = 1;
    }
};
Trie *root = NULL;
void Insert(char *word)
{
    Trie *cur = root;
    int i,len;
    len = strlen(word);
    for(i = 0; i < len; i++)
    {
        int id = word[i]-'a';
        if(cur->child[id] == NULL)
            cur->child[id] = new Trie;
        else
            cur->child[id]->num++;
        cur = cur->child[id];
    }
}
int F(char *word)
{
    Trie *cur = root;
    int i,len;
    len = strlen(word);
    for(i = 0; i < len; i++)
    {
        int id = word[i]-'a';
        cur = cur->child[id];
        if(cur == NULL)
            return 0;
    }
    return cur->num;
}
int main()
{
    root = new Trie;
    while(gets(s) && s[0]!='\0')
    {
        Insert(s);
    }
    while(scanf("%s",s)!=EOF)
    {
        printf("%d\n",F(s));
    }
    return 0;
}

POJ 2001    点击此处 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 26;
const int N = 1000+10;
const int M = 21;
char dic[N][M];
struct Trie
{
    int childNum;
    Trie *child[maxn];
    Trie()
    {
        for(int i = 0; i < maxn; ++i)
            child[i] = NULL;
        childNum = 1;
    }
};
Trie *root = NULL;
void Insert(char *word)
{
    Trie *cur = root;
    int len = strlen(word);
    for(int i = 0; i < len; ++i)
    {
        int id = word[i]-'a';
        if(cur->child[id] == NULL)//下继存在就开一个空间
            cur->child[id] = new Trie;
        else
            cur->child[id]->childNum++;
        cur = cur->child[id];
    }
}
int findshortest(char *word)
{
    int i,len = strlen(word);
    Trie *cur = root;
    for(i = 0; i < len; ++i)
    {
        int id = word[i]-'a';
        cur = cur->child[id];
        if(cur->childNum <= 1)
            return i;
    }
    return -1;
}
int main()
{
    int ant = 0;
    root = new Trie;
    while(scanf("%s",dic[ant])!=EOF)
        Insert(dic[ant++]);
    for(int j = 0; j < ant; j++)
    {
        int ans = findshortest(dic[j]);
        if(ans == -1)
            printf("%s %s\n",dic[j],dic[j]);
        else
        {
            printf("%s ",dic[j]);
            dic[j][ans+1] = '\0';
            printf("%s\n",dic[j]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值