LightOJ 1214-Large Division-int整除大数

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print ‘divisible’ if a is divisible by b. Otherwise print ‘not divisible’.

Sample Input

6
101 101
0 67
-101 101
7678123668327637674887634 101
11010000000000000000 256
-202202202202000202202202 -101

Sample Output

Case 1: divisible
Case 2: divisible
Case 3: divisible
Case 4: not divisible
Case 5: divisible
Case 6: divisible

题目大意:

给定一个200位的大数a和一个int类型的数b,问b能否整除a。

核心思想:

以字符串类型读取a,存在s[n]中,以int类型读取b。
遍历a的每一位,每遍历一位进行以下操作:
1、a=a*10+s[i]-‘0’
2、a%=b

最后判断a是否为0,是则可以整除,否则不可整除。

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
char s[450];
int main()
{
	int T,ca=0;
	ll a,b;
	cin>>T;
	while(T--)
	{
		scanf("%s%lld",s,&b);
		int len=strlen(s);
		//处理符号 
		if(b<0)
			b=-b;
		int k;
		if(s[0]=='-') k=1;
		else k=0;
		//遍历s
		a=0;
		for(int i=k;i<len;i++)
		{
			a=a*10+s[i]-'0';
			a%=b;
		}
		if(a)
			printf("Case %d: not divisible\n",++ca);
		else
			printf("Case %d: divisible\n",++ca);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值