HDU 3652-B-number-数位dp-模板

Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string “13” and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13
100
200
1000

Sample Output

1
1
2
2

核心思想:

数位dp模板题。

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=11,M=13,K=3;
//dp[i][j][k]表示还有i位,高位的数对13取余为j
//k=2表示高位出现过13,否则,i+1位是1则k=1,是0则k=0 
int dp[N][M][K],p[N];
int dfs(int pos,int mo,int k,int lim)
{
	if(!pos)
		return !mo&&k==2;//判断是否满足题目条件 
	if(!lim&&dp[pos][mo][k]!=-1)
		return dp[pos][mo][k];
	int end=lim?p[pos]:9;
	int tm,tk,ans=0;
	for(int i=0;i<=end;i++)
	{
		tm=(mo*10+i)%13;
		if(k==2)
			tk=2;
		else if(k==1&&i==3)
			tk=2;
		else
			tk=(i==1);
		ans+=dfs(pos-1,tm,tk,lim&&i==end);
	}
	if(!lim)
		return dp[pos][mo][k]=ans;
	return ans;
}
int main()
{
	int n;
	//初始化 
	for(int i=0;i<N;i++)
		for(int j=0;j<M;j++)
			for(int z=0;z<K;z++)
				dp[i][j][z]=-1;
	//输入 
	while(scanf("%d",&n)!=EOF)
	{
		//按位拆分 
		int t=n,i=1;
		while(t)
		{
			p[i++]=t%10;
			t/=10;
		}
		//输出 
		printf("%d\n",dfs(i-1,0,0,1));
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值