Color the ball

Color the ball

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19849 Accepted Submission(s): 9897


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input
  
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0

Sample Output
  
  
1 1 1 3 2 1

Author
8600

Source

Recommend
LL | We have carefully selected several similar problems for you: 1166 1542 1394 1698 1255
代码写出来了,但是一开始不知道原理是什么,然后突然看到了另一份代码就懂了。
#include<stdio.h>  
#include<string.h>  
int s[100100];  
int main(){  
    int n;  
    while(~scanf("%d",&n)&&n){  
        int i,j,k;  
        int x,y;  
        memset(s,0,sizeof(s));  
        for(i=1;i<=n;i++){  
            scanf("%d %d",&x,&y);  
            s[x]++;  
            s[y+1]--;  
        }  
        int sum=0;  
        for(i=1;i<n;i++){  
            sum+=s[i];  
            printf("%d ",sum);  
        }  
        sum+=s[i];  
        printf("%d\n",sum);  
    }  
    return 0;  
} 
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int Maxn=100000;
int sum[1000005],n;
int lowbit(int x){
    return x&(-x);
}
void updata(int x,int cnt){
    while(x<=Maxn){
        sum[x]+=cnt;
        x+=lowbit(x);
    }
}
int getSum(int x){
    int s=0;
    while(x>0){
        s+=sum[x];
        x-=lowbit(x);
    }
    return s;
}
int main(){
   // freopen("in.txt","r",stdin);
    while(scanf("%d",&n)&&n){
        memset(sum,0,sizeof(sum));
        for(int l,r,i=1;i<=n;i++){
            scanf("%d%d",&l,&r);
            updata(l,1);
            updata(r+1,-1);
        }
        for(int i=1;i<n;i++) printf("%d ",getSum(i));
        printf("%d\n",getSum(n));
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值