J - 2016 CSU - 1803


给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:

1. 1≤a≤n,1≤b≤m;

2. a×b 是 2016 的倍数。
Input

输入包含不超过 30 组数据。

每组数据包含两个整数 n,m (1≤n,m≤10  9).
Output
对于每组数据,输出一个整数表示满足条件的数量。
Sample Input
32 63
2016 2016
1000000000 1000000000
Sample Output
1
30576
7523146895502644

#include<iostream>
#include<stdio.h>
using namespace std;
typedef long long ll;
const int mod=2016;
int gcd(int a,int b){
    return b?gcd(b,a%b):a;
}
int main(){
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF){
        ll ans=0;
        for(int i=0;i<mod;i++){
            ll cnt1=(a-i)/mod+1;
            if(i>a) break;
            if(i==0){
                ans+=(cnt1-1)*(ll)b;
            }
            else{
                int d=gcd(mod,i);
                int x=mod/d;
                ll cnt2=b/x;
                ans+=cnt1*cnt2;
            }
        }
        printf("%lld\n",ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值