PAT Advanced 1013. Battle Over Cities (25)(C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

It is vitally important to have all the cities connected by highways in a war.
If a city is occupied by the enemy, all the highways from/toward that city are
closed. We must know immediately if we need to repair any other highways to
keep the rest of the cities connected. Given the map of cities which have all
the remaining highways marked, you are supposed to tell the number of highways
need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting c i t y 1 city_1 city1 - c i t y 2 city_2 city2
and c i t y 1 city_1 city1 - c i t y 3 city_3 city3 . Then if c i t y 1 city_1 city1 is occupied by the enemy, we must
have 1 highway repaired, that is the highway c i t y 2 city_2 city2 - c i t y 3 city_3 city3 .

Input Specification:

Each input file contains one test case. Each case starts with a line
containing 3 numbers N N N ( &lt; 1000 &lt;1000 <1000 ), M M M and K K K , which are the total number
of cities, the number of remaining highways, and the number of cities to be
checked, respectively. Then M M M lines follow, each describes a highway by 2
integers, which are the numbers of the cities the highway connects. The cities
are numbered from 1 to N N N . Finally there is a line containing K K K numbers,
which represent the cities we concern.

Output Specification:

For each of the K K K cities, output in a line the number of highways need to be
repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

思路

题目即要求我们计算这些城市有几个内部相连的部分。

思路是对这些城市和公路组成的图进行多次遍历,直至所有城市都被遍历位置,遍历次数减1即为需要修复的公路数量。

具体遍历时,逐一城市进行一个更高层的循环,跳过已遍历过的即可。

代码

最新代码@github,欢迎交流

#include <stdio.h>

#define MAX 1000

void DFS(int v, int known[], int G[][MAX])
{
    known[v] = 1;
    for(int i = 0; i < MAX; i++)
        if((G[v][i] || G[i][v]) && !known[i])
            DFS(i, known, G);
}

int main()
{
    int N, M, K;
    scanf("%d %d %d", &N, &M, &K);

    int Graph[MAX][MAX] = {{0}};

    int city1, city2;
    for(int i = 0; i < M; i++)
    {
        scanf("%d %d", &city1, &city2);
        Graph[city1][city2] = 1;
    }

    for(int i = 0; i < K; i++)
    {
        int known[MAX] = {0}, lostcity, count = 0;
        scanf("%d", &lostcity);

        known[lostcity] = 1;
        for(int i = 1; i <= N; i++) if(!known[i])
        {
            DFS(i, known, Graph);
            count++;
        }
        printf("%d\n", count - 1);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值