PAT Advanced 1019. General Palindromic Number (20) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

A number that will be the same when it is written forwards or backwards is
known as a Palindromic Number. For example, 1234321 is a palindromic
number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system,
the concept of palindromicity can be applied to the natural numbers in any
numeral system. Consider a number N > 0 N > 0 N>0 in base b ≥ 2 b \ge 2 b2 , where it is
written in standard notation with k + 1 k+1 k+1 digits a i a_i ai as ∑ i = 0 k ( a i b i ) \sum_{i=0}^k (a_ib^i) i=0k(aibi) . Here, as usual, 0 ≤ a i &lt; b 0 \le a_i &lt; b 0ai<b for all i i i and a k a_k ak is non-zero.
Then N N N is palindromic if and only if a i = a k − i a_i = a_{k-i} ai=aki for all i i i . Zero is
written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N N N and a base b b b , you are supposed to
tell if N N N is a palindromic number in base b b b .

Input Specification:

Each input file contains one test case. Each case consists of two positive
numbers N N N and b b b , where 0 &lt; N ≤ 1 0 9 0 &lt; N \le 10^9 0<N109 is the decimal number and 2 ≤ b ≤ 1 0 9 2 \le b \le 10^9 2b109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N N N is a palindromic
number in base b b b , or No if not. Then in the next line, print N N N as the
number in base b b b in the form " a k a_k ak a k − 1 a_{k-1} ak1 a 0 a_0 a0 ". Notice that
there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

鸣谢网友“CCPC拿不到牌不改名”修正数据!

思路

综合考察进制转换和回文数检查,两个都相对简单,大家可以直接看代码。

代码

最新代码@github,欢迎交流

#include <stdio.h>

int main()
{
    int N, b, c, isPalindromicNumber = 1, b_base[30] = {0};

    scanf("%d %d", &N, &b);

    /* Calculate N in b-base */
    for(c = 0; N; N /= b, c++)
        b_base[c] = N % b;

    /* Check if it is palindromic number */
    for(int i = 0; i < c / 2; i++)
        if(b_base[i] != b_base[c - i - 1])
            isPalindromicNumber = 0;
    puts(isPalindromicNumber ? "Yes" : "No");

    if(c == 0)
        printf("0");
    /* Reversely printing is the correct order */
    while(c--)
        printf("%d%c", b_base[c], c ? ' ' : '\0');

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值