POJ3253 求出花费最少的钱

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

------------------------------------------------------

思路:因为给定的长度就是21 ,所以求解时可以直接设定一个len,cost。每次的cost加上剩余的len。虽然这样可以做出来,但那不一定是最小的那个值。因为是求最小的造价,所以可以考虑哈弗曼树的思想。选出两个最小的,得到他们的值再放入数据中,继续得出最小的值。这样也可以做出来,得到的值也是正确的,但是会超时,改程序时把这些代码删了,所以这种方法就没有办法附代码了。还有一种就是利用优先队列,这是我通过看别人的想法才知道,通过了。其实这个题目没有很多的算法,关键就是看怎么提高程序的效率,如利用一些系统已给定的函数什么的。

-----------------------------------------------------

#include<iostream>

#include<vector>
#include<queue>
using namespace std;
class cmp//比较规则,最小优先  
{
public:
bool operator()(const __int64 a,const __int64 b)const  
{
return  a > b;
}  
};
int main(void)
{
int n; //需要切割的木板个数 
while (cin >> n)
{
priority_queue<__int64,vector<__int64>,cmp>Queue;        //优先队列
for (int i = 1; i <= n; i++)
{
__int64 temp; 
scanf("%I64d",&temp);  
Queue.push(temp);//输入要求的木板长度(费用)并入队 
}
__int64 mincost = 0; //最小费用  
while (Queue.size()>1)//当队列中小于等于一个元素时跳出
{
__int64 a = Queue.top();//得到队首元素的值,并使其出队 
Queue.pop();
__int64  b = Queue.top();//两次取队首,即得到最小的两个值  
Queue.pop();
Queue.push(a + b);
mincost += a + b;
}

printf("%I64d\n",mincost); 

// while(!Queue.empty())  //清空队列  ,可以节省存储空间,对提高运算时间没关系
      //      Queue.pop();  
   // }  

}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值