SDUT 1197 约瑟夫问题

1.问题

约瑟夫问题
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
n个人想玩残酷的死亡游戏,游戏规则如下:

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。
Input
输入n和m值。
Output
输出胜利者的编号。
Sample Input

5 3

Sample Output

4

Hint
第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀

2.正确代码

#include <stdio.h>
#include <stdlib.h>

struct node {
    struct node *next;
    int data;
};

//建立循环链表
struct node * create(int n)
{
    struct node *head,*p,*t,*tail;

    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;

    for(int i=1;i<=n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->data=i;
        p->next=NULL;

        tail->next=p;
        tail=p;
    }


    tail->next=head->next;

    return head;
}

int kill(struct node *head,int m)
{
    while(head->next!=head)
    {
        for(int i=1;i<=m-1;i++)
        {
            head=head->next;
        }
        head->next=head->next->next;
    }

    return head->data;

}

int main()
{
    struct node *head;
    int n,m,num;
    scanf("%d %d",&n,&m);

    head=create(n);

    num = kill(head,m);

    printf("%d\n",num);

    return 0;

}

3.解题思路:

1.构建循环链表:

0
1 2 3
5 4

注意,5和1连接,从head进入,之后循环中不会存在head了,就是这个道理。
循环m-1次,到被杀者前面一位,之后 head->next=head->next->next,断开前一位的连接,直接抛弃被杀者,之后循环就很好建立起来了。

这题难度不大,很简单。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值