hdu 5326

Work

Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
  
  
2
 

题目大意:给出n个人 和 k ,n-1行(a,b)表示a是b的直属上司,要求找出管理k个人的人的个数

思        路:   链式前向星+dfs 
                   
                    链式前向星存储边的时候大大节省了空间和时间,比直接存邻接表要快很多,dfs遍历那些没有被记录过的点
                    就找到答案了。

代码如下:
/*踏实!!努力!!*/
#include<iostream>
#include<stdio.h>
#include<cmath>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
using namespace std;
struct{
    int v,next;
}edge[150];
int cnt,head[150],visit[150],index[150],ans;
int num[150],n,k;

void add(int u,int v)
{
    edge[cnt].v=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
    return;
}

void dfs(int u)
{
    visit[u]=1;
    index[u]=0;
    for(int i=head[u];i!=-1;i=edge[i].next){
        int to=edge[i].v;
        if(!visit[to]){
            dfs(to);
            index[u]+=(index[to]+1);
        }
    }
    if(index[u]==k)
        ans++;
    return ;
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF){
        memset(num,0,sizeof(num));
        memset(head,-1,sizeof(head));
        memset(visit,0,sizeof(visit));
        ans=cnt=0;

        for(int i=1;i<n;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            add(a,b);
            num[b]++;
        }

        //找出那些未被标记过的点
        for(int i=1;i<=n;i++)
            if(!num[i])
               dfs(i);

        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值