hdu5326 树形dp

C - Work
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description



It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company. 
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B. 
Now, give you the relation of a company, can you calculate how many people manage k people. 

Input

There are multiple test cases. 
Each test case begins with two integers n and k, n indicates the number of stuff of the company. 
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B. 

1 <= n <= 100 , 0 <= k < n 
1 <= A, B <= n 

Output

For each test case, output the answer as described above.

Sample Input

7 2
1 2
1 3
2 4
2 5
3 6
3 7

Sample Output

2

题意:

在一个公司里,A - B B-C 表示A是B的直接上级,B是C的直接上级,A是C的间接上级,不管是直接上级环视间接上级

都属于A的管辖人员,有n个员工n-1条关系(树形关系网),问管辖K个人的人有多少个;

树形dp嘛,问几个节点有K个孩子,但是有一个坑,有可能有多个树根,有可能 A-B C-B ,这种关系,A C 关系,但是

A C 都管辖B,所以要在每个树根处都要进行dfs,每棵树上的管辖k个人的节点都要计算入结果

#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
const int maxn=1000;
vector<int>edge[maxn];
int ru[maxn];
int leaf[maxn];
void dfs(int u,int pre)
{
    if(edge[u].size()==0)
    {
        return;
    }
    for(int i=0; i<edge[u].size(); i++)
    {
        int v=edge[u][i];
        if(v==pre)
            continue;
        dfs(v,u);
        leaf[u]+=leaf[v];
    }

}
int main()
{
    int n,k;
    int u,v;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(ru,0,sizeof(ru));
        for(int i=1; i<=n; i++)
        {
            edge[i].clear();
            leaf[i]=1;
        }
        for(int i=1; i<n; i++)
        {
            scanf("%d%d",&u,&v);
            {
                ru[v]++;
                edge[u].push_back(v);
               // edge[v].push_back(u);
            }
        }

        int ans=0;
        int root;
        for(int i=1; i<=n; i++)
        {
            if(ru[i]==0)
            {
                for(int i=1;i<=n;i++)
                    leaf[i]=1;
                dfs(i,0);
                for(int i=1;i<=n;i++)
                {
                      //cout<<i<<" "<<leaf[i]-1<<" ";
                    if(leaf[i]-1==k)
                        ans++;
                }
            }

        }




        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值