hdu 5360

Hiking

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 771    Accepted Submission(s): 408
Special Judge


Problem Description
There are  n  soda conveniently labeled by  1,2,,n . beta, their best friends, wants to invite some soda to go hiking. The  i -th soda will go hiking if the total number of soda that go hiking except him is no less than  li  and no larger than  ri . beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than  li  and no larger than  ri , otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n105) , the number of soda. The second line constains  n  integers  l1,l2,,ln . The third line constains  n  integers  r1,r2,,rn (0lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.
 

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of  1,2,,n  denoting the invitation order. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 8 4 1 3 2 2 1 0 3 5 3 6 4 2 1 7 6 8 3 3 2 0 5 0 3 6 4 5 2 7 7 6 7 6 8 2 2 3 3 3 0 0 2 7 4 3 6 3 2 2 5 8 5 6 5 3 3 1 2 4 6 7 7 6 5 4 3 5
 

Sample Output
  
  
7 1 7 6 5 2 4 3 8 8 4 6 3 1 2 5 8 7 7 3 6 7 1 5 2 8 4 0 1 2 3 4 5 6 7 8
 


题目大意:根据n个人的可接受范围,要求找出人数最多的可行方案

思        路 :贪心+mutilset容器

                    每个人的可接受范围是l - r    将当前可以接受的人全部写入set  但是加入的是r最小的那个人

                    同时将不满足r 的人删出set  直至set为空

                    很巧妙的思路,当遇到既考虑左区间有考虑右区间的问题时,在左区间排列的基础上找出右区间

                    对应的顺序,看破这一点很重要,最近的多校题都很巧妙的利用set的特点自动排序,而multiset

                   不同于set的地方就在于可以重复出现,也就是不会消重。

 

                   mutilset  

                   1:不会消重

                  2: erase(X) 函数删处的时候会将所有X删除

代码如下:

/*踏实!!努力!!*/
#include<iostream>
#include<stdio.h>
#include<cmath>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<set>
#include<algorithm>
using namespace std;
#define N 100005
multiset<pair<int,int> > P;//注意定义方式
struct Node{
    int l,r,id;
};
Node data[N];
bool cmp(Node a,Node b)
{
    if(a.l==b.l)
        return a.r<b.r;
    return a.l<b.l;
}
int main()
{
    int t;
    int n,visit[N],i;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(i=1;i<=n;i++){
            data[i].id=i;
            scanf("%d",&data[i].l);
        }
        for(i=1;i<=n;i++)
            scanf("%d",&data[i].r);
        sort(data+1,data+1+n,cmp);

        int ans=0;
        int num=1;
        int cnt[N];
        memset(visit,0,sizeof(visit));
        multiset<pair<int,int> > ::iterator it; //迭代器
        while(1){
            //可接受范围内的所有值都进set
            while(ans>=data[num].l&&num<=n){
                P.insert(make_pair(data[num].r,data[num].id));
                num++;
            }
            if(!P.size())
                break;
            //删除不接受的人
            while(P.size()){
                it=P.begin();
                if(ans<=it->first)
                    break;
                P.erase(P.begin());
            }
            //选定当前的人加入 同时在set里删除该人
            if(P.size()){
                it=P.begin();
                cnt[++ans]=it->second;
                visit[it->second]=1;
                P.erase(it);
            }
        }
        printf("%d\n",ans);
        for(i=1;i<=n;i++)
            if(!visit[i])
               cnt[++ans]=i;
        printf("%d",cnt[1]);
        for(i=2;i<=ans;i++)
            printf(" %d",cnt[i]);
        printf("\n");
    }
    return 0;
}

 

                   

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值