HDU 1028 Ignatius and the Princess III(母函数)

传送门

Problem Description

“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

这个题有多种解法,可以dp,也可以搜索,也可以母函数,本文是用母函数解决的该问题。
首先有 N=a[1]+a[2]+a[3]+…+a[m];那么我们可以想到该个数字可以由1~N内的数字来构成。
那么N的方案数就是 ( 1 + x + x 2 + ⋯ + x n ) ∗ ( 1 + x 2 + x 4 + ⋯ + x 2 n ) ∗ ⋯ ∗ ( 1 + x n ) (1+x+x^2+\dots +x^n)*(1+x^2+x^4+\dots +x^{2n})*\dots*(1+x^n) (1+x+x2++xn)(1+x2+x4++x2n)(1+xn) x N x^N xN的系数,所以我们只需要计算出 x N x^N xN的系数即可。

AC代码如下:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N(1e3);
int a[N],b[N];
int main()
{
	int n;
	while(cin>>n){
		memset(a,0,sizeof a);
		memset(b,0,sizeof b);
		b[0]=1;
		for(int i=1;i<=n;i++){
			for(int j=0;j<=n;j++)
			{
				for(int k=0;k<=n-j;k+=i){
					a[j+k]+=b[j];
				}
			}
			for(int j=0;j<=n;j++){
				b[j]=a[j];
				a[j]=0;
			}
		}
		cout<<b[n]<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值