pat a1053 给定权值和,求路径

题目:

https://pintia.cn/problem-sets/994805342720868352/problems/994805424153280512

https://www.nowcoder.com/pat/5/submission-detail/64114048

1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

 

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;

const int maxn=110;

struct Node
{
	int weight;  //数据域 
	vector<int> child;   //指针域 
}node[maxn];  //结点数组 

bool cmp(int a,int b)
{
	return node[a].weight>node[b].weight; //按结点数据域从大到小排序 
}

int n,m,S;  //结点数、分支结点数、给定的和 
int path[maxn];  //记录路径 

//当前访问结点为index,numNode为当前路径path上的结点个数 
//sum为当前的结点权值之和 
void DFS(int index,int numNode,int sum)
{
	if(sum>S) return;
	if(sum==S) 
	{
		if(node[index].child.size()!=0) return;
		for(int i=0;i<numNode;i++)
		{
			printf("%d",node[path[i]].weight);
			if(i<numNode-1) printf(" ");
			else printf("\n");
		}
		return;
	}
	for(int i=0;i<node[index].child.size();i++)
	{
		int child=node[index].child[i];
		path[numNode]=child;
		DFS(child,numNode+1,sum+node[child].weight);
	}	
}

int main()
{
	scanf("%d%d%d",&n,&m,&S);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&node[i].weight);
	}
	int id,k,child;
	for(int i=0;i<m;i++)
	{
		scanf("%d%d",&id,&k);
		for(int j=0;j<k;j++)
		{
			scanf("%d",&child);
			node[id].child.push_back(child);
		}
		sort(node[id].child.begin(),node[id].child.end(),cmp);
	}
	path[0]=0;
	DFS(0,1,node[0].weight);
	
	return 0;	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
哈夫曼树是一种带有权值的二叉树,它的构造方法是通过贪心策略,将权值最小的两个节点合并成一个新节点,直到最后只剩下一个节点为止。下面是给定权值构造哈夫曼树的详细步骤: 1. 将所有权值作为叶子节点,构造一个节点集合。 2. 从节点集合中选出两个权值最小的节点,合并成一个新节点,权值为两个节点的权值之和。 3. 将新节点加入节点集合中,并删除原来的两个节点。 4. 重复步骤2和3,直到节点集合中只剩下一个节点为止,这个节点就是哈夫曼树的根节点。 下面是一个示例,假设给定权值为[5, 9, 12, 13, 16, 45]: 首先构造出6个叶子节点: ``` 5 9 12 13 16 45 / / / / / / A B C D E F ``` 然后按照上面的步骤,合并权值最小的两个节点: ``` 5 9 12 13 16 45 / / / / / A B C D ┌────F │ 61 │ └────E ``` 继续合并权值最小的两个节点: ``` 5 9 12 13 16 45 / / / / / / A B C ┌────D E F │ 25 │ └─────┐ │ 36 │ └────C ``` 继续合并权值最小的两个节点: ``` 5 9 12 13 16 45 / / / / / / A B ┌─────┐ D E F │ │ 25 36 │ │ └─────┘ │ 61 │ └────C ``` 最后只剩下一个节点,它就是哈夫曼树的根节点: ``` 111 / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ / \ 5 106 / \ / \ / \ / \ / \ / \ A B C 61 / \ / \ D E ``` 因此,给定权值构造出的哈夫曼树就是上面的树形结构。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值