Have Fun with Numbers

自测-4 Have Fun with Numbers (20分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899

Sample Output:
Yes
2469135798


思路:
1,通过提交答案可以看出出题者在进行数字计算时使用的方法是用unsigned long 定义过长的数字串,但本题也完全可以用打数相加的方法处理数字。
2,使用数组b[10],记忆计算后的数所出现的数字,再与输入时的数进行比较,即可得解。


代码:

#include<stdio.h>
#include<string.h> 

int main(){
	char sum[30];
	gets(sum);
	int sun[30],n,t,m;
	n=strlen(sum);
	m=n;
	t=0;
	for(int i=0;i<n;i++){
		sun[n-1-i]=sum[i]-'0';
		//这里将数组倒置,即sun为后续中的输入数字串
		//(char-'0'==int) 
	}
	for(int i=0;i<n;i++){
		sum[i]=(sun[i]*2+t)%10+'0';
		t=(sun[i]*2+t)/10;
		if(t&&i==n-1){
			sum[n]=1+'0';
			//sum为输出串 
			n++;
		}
	}
	t=1;
	//这里将t用作判断数字重复的变量 
	int b[10];
	for(int i=0;i<10;i++){
		b[i]=0;
	}
	for(int i=0;i<m;i++){
		b[sum[i]-'0']=1;
	}
	for(int i=0;i<n;i++){
		if(b[sun[i]]!=1){
			t=0;
			break;
		}
	}
	
	if(t){
		printf("Yes\n");
	}
	else{
		printf("No\n");
	}
		for(int i=n-1;i>=0;i--){
		printf("%c",sum[i]);
	}
} 

总结:
1,char型可以通过-‘0’,当作int进行使用;
2,一定要搞清楚自己各个变量代表的“物”,,,,

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值