PAT Advanced 1023. Have Fun with Numbers (20) (C语言实现)

该博客介绍了PAT考试中的一道题目,涉及大数运算和数字排列的问题。作者提供了一个C语言的解决方案,解释了思路并给出了代码实现。通过检查一个数的两倍是否由原始数的数字重新排列组成来判断条件。
摘要由CSDN通过智能技术生成

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

Notice that the number 123456789 is a 9-digit number consisting exactly the
numbers from 1 to 9, with no duplication. Double it we will obtain 246913578,
which happens to be another 9-digit number consisting exactly the numbers from
1 to 9, only in a different permutation. Check to see the result if we double
it again!

Now you are suppose to check if there are more numbers with this property.
That is, double a given number with k k k digits, you are to tell if the
resulting number consists of only a permutation of the digits in the original
number.

Input Specification:

Each input contains one test case. Each case contains one positive integer
with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number
gives a number that consists of only a permutation of the digits in the
original number, or “No” if not. Then in the next line, print the doubled
number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路

主要是大数运算,这里是大数和个位数的乘法,我的简要思路是:

  • 用字符数组倒序存储数字,即小序数的地方存低位数字。
  • 做乘法,模拟手算,注意字符和数字的转换:
    • s代表算出的当前位,
    • l代表当前剩余的进位数字,在下一次计算时,加上此数字。
  • 将结果再翻转回来,便于输出。
  • 统计两个数包含数字的数量之差,按要求输出即可。

代码

最新代码@github,欢迎交流

#include <stdio.h>
#include <string.h>

void reverse(char n[])
{
    char temp;
    int len = strlen(n);
    for(int i = 0; i < len / 2; i++)
    {
        temp = n[i];
        n[i] = n[len - i - 1];
        n[len - i - 1] = temp;
    }
}

void doubleLargeNumber(char n[], char n2[])
{
    int l, s = 0, len = strlen(n);

    for(int i = 0; i < len; i++)
    {
        s += 2 * (n[i] - '0');
        l = s / 10;
        s %= 10;
        n2[i] = s + '0';

        s = l;
    }

    if(s)
        n2[len] = s + '0';
}

int main()
{
    char N[22] = {0}, N2[22] = {0};
    int diffcount[10] = {0};

    scanf("%s", N);
    /* store number in reverse order */
    reverse(N);
    doubleLargeNumber(N, N2);
    /* reverse back (just need N2) for printing */
    reverse(N2);

    /* Count the difference of counts of digits 0-9 */
    for(int i = 0; i < strlen(N); i++)
        diffcount[N[i] - '0']++;
    for(int i = 0; i < strlen(N2); i++)
        diffcount[N2[i] - '0']--;

    /* Check */
    for(int i = 0; i < 10; i++)
        if(diffcount[i])
        {
            printf("No\n%s", N2);
            return 0;
        }
    printf("Yes\n%s", N2);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值