HDU 3336 Count the string

Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
1
4
abab

Sample Output
6


【题目大意】
要求求出所有前缀在字符串中的出现的次数之和。


【题目分析】
用f[i]来表示s[1]-s[i]的包含的全部的前缀的总次数。那么f[i]=f[next[i]]+1。这是显然成立的,对于这样的前缀,它同样也包含他的next指向的字符串的次数。所以需要进行累加操作,然后再对数列f求一个和就是答案了。


【代码】

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
char a[200001];
int dp[200001],ne[200001];
int main()
{
    int tt;
    scanf("%d",&tt);
    while (tt--)
    {
        dp[1]=1;ne[1]=0;
        int l,ans=1;
        scanf("%d%s",&l,a+1);
        for (int i=2,j=0;i<=l;++i)
        {
            while (j&&a[j+1]!=a[i]) j=ne[j];
            if (a[j+1]==a[i]) j++;
            ne[i]=j;
            if (j>0) dp[i]=(dp[j]+1)%10007;
            else dp[i]=1;
            (ans+=dp[i])%=10007;
        }
        cout<<ans<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值