hdu6045 Is Derek lying?

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1162    Accepted Submission(s): 629


Problem Description
Derek  and  Alfia  are good friends. Derek  is Chinese,and  Alfia  is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of  N  choice questions and each question is followed by three choices marked “ A ” “ B ” and “ C ”.Each question has only one correct answer and each question is worth  1  point.It means that if your answer for this question is right,you can get  1  point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell  Derek  the total score of him and  Alfia .Then  Alfia  will ask  Derek  the total score of her and he will tell her: “My total score is  X ,your total score is  Y .”But  Derek  is naughty,sometimes he may lie to her. Here give you the answer that  Derek  and  Alfia  made,you should judge whether  Derek  is lying.If there exists a set of standard answer satisfy the total score that  Derek  said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer  T ,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers  N , X , Y ,the meaning is mentioned above.

The second line consists of  N  characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of  Derek  for each question.

The third line consists of  N  characters,the same form as the second line,which represents the answer of  Alfia  for each question.

Data Range: 1N80000 , 0X,YN, Ti=1N300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying ” if you can make sure that  Derek  is lying,otherwise please print “ Not lying ”.
 

Sample Input
  
  
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
 
Sample Output
   
   
Not lying Lying
 
题目意思是Derek和Alfia共同做了n道选择题,给出两人的答案和得分,问是否存在满足这种得分的情况
解题思路:两人的回答只有两种,一种回答相同,一种不同;相同的回答要么都对(记为a),要么都错(记为b),不同的回答,要么都错,要么一个对一个错;然后很容易得出约束条件|x-y|<b;x+y<a*2+b;因此只要记录两种回答的个数a,b判断是否满足条件就行了

代码如下:
#include <bits/stdc++.h>
using namespace std;
int main()
{
	std::ios::sync_with_stdio(false);
	int T,n,x,y;
	int a,b,i;
	string s1,s2;
	cin>>T;
	while(T--)
	{
		cin>>n>>x>>y;
		cin>>s1;
		cin>>s2;
		a=0;
		b=0;
		for(i=0;i<n;i++)
		{
			if(s1[i]==s2[i])
				a++;
			else
				b++;
		}
		if(abs(x-y)<=b&&(x+y)<=2*a+b)
			cout<<"Not lying"<<endl;
		else
			cout<<"Lying"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值