ZOJ Problem Set - 3962

Seven Segment Display

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

Edward, a student in Marjar University, is studying the course "Logic and Computer Design Fundamentals" this semester. He bought an eight-digit seven segment display component to make a hexadecimal counter for his course project.

In order to display a hexadecimal number, the seven segment display component needs to consume some electrical energy. The total energy cost for display a hexadecimal number on the component is the sum of the energy cost for displaying each digit of the number. Edward found the following table on the Internet, which describes the energy cost for display each kind of digit.

DigitEnergy Cost
(units/s)
06
12
25
35
44
55
66
73
DigitEnergy Cost
(units/s)
87
96
A6
B5
C4
D5
E5
F4

For example, in order to display the hexadecimal number "5A8BEF67" on the component for one second, 5 + 6 + 7 + 5 + 5 + 4 + 6 + 3 = 41 units of energy will be consumed.

Edward's hexadecimal counter works as follows:

  • The counter will only work for n seconds. After n seconds the counter will stop displaying.
  • At the beginning of the 1st second, the counter will begin to display a previously configured eight-digit hexadecimal number m.
  • At the end of the i-th second (1 ≤ i < n), the number displayed will be increased by 1. If the number displayed will be larger than the hexadecimal number "FFFFFFFF" after increasing, the counter will set the number to 0 and continue displaying.

Given n and m, Edward is interested in the total units of energy consumed by the seven segment display component. Can you help him by working out this problem?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 105), indicating the number of test cases. For each test case:

The first and only line contains an integer n (1 ≤ n ≤ 109) and a capitalized eight-digit hexadecimal number m (00000000 ≤ m ≤ FFFFFFFF), their meanings are described above.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case output one line, indicating the total units of energy consumed by the eight-digit seven segment display component.

Sample Input
3
5 89ABCDEF
3 FFFFFFFF
7 00000000
Sample Output
208
124
327
Hint

For the first test case, the counter will display 5 hexadecimal numbers (89ABCDEF, 89ABCDF0, 89ABCDF1, 89ABCDF2, 89ABCDF3) in 5 seconds. The total units of energy cost is (7 + 6 + 6 + 5 + 4 + 5 + 5 + 4) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 6) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 2) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) = 208.

For the second test case, the counter will display 3 hexadecimal numbers (FFFFFFFF, 00000000, 00000001) in 3 seconds. The total units of energy cost is (4 + 4 + 4 + 4 + 4 + 4 + 4 + 4) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 6) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 2) = 124.



题意:给出两个数m,n。 要求出m,m+1,m+2,,,,m+n-1上述数字的比划之和。

因为m,n数字比较大,所以不能直接先求单个数字再相加。可采用一种前缀和的思想,定义函数f(x)为1,2,,,x的比划和,则f(m+n-1)-f(m-1)即为所求。

至于求f(x),可以分别求每一位所需的总比划,由3部分组成,在程序注释中。此题不难,关键在于一些细节方面容易出错,另外如果用pow()函数会超时,应改为移位操作。


AC代码:

#include<bits/stdc++.h>
#define outl(x)	cout<<#x" = "<<x<<endl
#define out(x)	cout<<#x" = "<<x<<' '
#define outs(_a, _n)	\
	cout<<#_a"[] = ";\
	for(int _i=0; _i<(_n); _i++)\
		cout<<_a[_i]<<' ';\
	cout<<endl;
using namespace std;
typedef long long ll; 

int bh[]={6,2,5,5,4,5,6,3,7,6,6,5,4,5,5,4};
int al;
ll f1(ll x, int s, int t){
	if(t<s)return 0;
	if(s==-1)return 0;
	x %= (ll)((ll)1<<(4*(t+1)));
	while(s--)x>>=4;
	return x;
}
ll f2(ll x, int d){
	ll ans=0;
	//第1部分,当前位前面的数字小于x前面部分时 
	ans+=(x/(ll)((ll)1<<(4*(d+1))))*(ll)((ll)1<<(4*(d)))*al;
	//第2部分,当前位前面的数字等于x前面部分,且当前位数字等于x当前位数字时 
	ans+=bh[f1(x,d,d)]*(f1(x,0,d-1)+1);
	//第3部分,当前位前面的数字等于x前面部分,且当前位数字小于x当前位数字时 
	for(int i=0;i<f1(x,d,d);i++)
		ans+=bh[i]*(ll)((ll)1<<(4*(d)));
	return ans;
}
ll f(ll x){
	if(x==-1)return 0;
	ll ans=0;
	//求每一位的比划和 
	for(int i=0;i<8;i++)
		ans+=f2(x,i);
	return ans;
}
int main(){
	for(int i=0;i<16;i++)
		al+=bh[i];
	int T;
	scanf("%d",&T);
	while(T--){
		ll t,x=0;
		char s[11];
		scanf("%d%s",&t,s);
		for(int i=0;i<8;i++){
			if(s[i]>='0'&&s[i]<='9')
				x+=(s[i]-'0')*(ll)((ll)1<<(4*(8-i-1)));
			else 
				x+=(s[i]-'A'+10)*(ll)((ll)1<<(4*(8-i-1)));
		}
		printf("%lld\n",f(x+t-1)-f(x-1));
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值