HDU-6045-Is Derek lying?

5 篇文章 0 订阅

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1598    Accepted Submission(s): 826


Problem Description
Derek  and  Alfia  are good friends. Derek  is Chinese,and  Alfia  is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of  N  choice questions and each question is followed by three choices marked “ A ” “ B ” and “ C ”.Each question has only one correct answer and each question is worth  1  point.It means that if your answer for this question is right,you can get  1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell  Derek  the total score of him and  Alfia .Then  Alfia  will ask  Derek  the total score of her and he will tell her: “My total score is  X ,your total score is  Y .”But  Derek  is naughty,sometimes he may lie to her. Here give you the answer that  Derek  and  Alfia  made,you should judge whether  Derek  is lying.If there exists a set of standard answer satisfy the total score that  Derek said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer  T ,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers  N , X , Y ,the meaning is mentioned above.

The second line consists of  N  characters,each character is “ A ” “ B ” or “ C ”,which represents the answer of  Derek  for each question.

The third line consists of  N  characters,the same form as the second line,which represents the answer of  Alfia  for each question.

Data Range: 1N80000 , 0X,YN, Ti=1N300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying ” if you can make sure that  Derek  is lying,otherwise please print “ Not lying ”.
 

Sample Input
  
  
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
 

Sample Output
  
  
Not lying Lying
   

解题代码
 
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
char ch[80005];
char sh[80005];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int N,X,Y;
        scanf("%d%d%d",&N,&X,&Y);
        getchar();
        scanf("%s",ch);
        getchar();
        scanf("%s",sh);
        int count1=0;
        int sum=X+Y;//计算两个人最大可能得到的分数总和最低应该是X+Y
        int mul=fabs(X-Y);//两个人不同的答案最低应该有X-Y个
        for(int i=0;i<N;i++)
        {
            if(ch[i]!=sh[i])
                count1++;
            if(count1==mul)
                break;
        }

        if(count1<mul)
        {
            printf("Lying\n");
            continue;
        }
        count1=0;
        for(int i=0;i<N;i++)
        {
            if(ch[i]==sh[i])//当两个人答案相同时都加分,当答案不同的时候随便一个加一分,
                count1+=2;//这样得到的才是两个得到的分数的总和的最大可能值

            else
                count1+=1;
            if(count1==sum)
                break;
        }
        if(count1<sum)
            printf("Lying\n");
        else
            printf("Not lying\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值