1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.(我们城市最高的建筑只有一部电梯。请求列表由N正数。数字表示电梯将按指定顺序在哪个楼层停止。将电梯向上移动一层需要 6 秒,向下移动一层需要 4 秒。电梯将在每个站停留5秒钟。)

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.(对于给定的请求列表,要计算完成列表中请求所花费的总时间。电梯在0楼开始时,在满足要求时不必返回一楼。)

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.(每个输入文件包含一个测试用例。每个案例都包含一个正整数N其次N正数。输入中的所有数字都小于 100。)

Output Specification:
For each test case, print the total time on a single line.(对于每个测试用例,在一行上打印总时间。)

Sample Input:
3 2 3 1
Sample Output:
41

n = input().split()
list1 = list(map(int, n))
output = list1[0]*5 + list1[1]*6
for i in range(2, len(list1)):
    if list1[i] > list1[i - 1]:
        output += (list1[i] - list1[i-1]) * 6
    if list1[i] < list1[i - 1]:
        output += (list1[i-1] - list1[i]) * 4
print(output)

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值