poj 1221 UNIMODAL PALINDROMIC DECOMPOSITIONS(递推/记忆化搜索+数学)

程序设计实习动态规划作业 poj 1221 UNIMODAL PALINDROMIC DECOMPOSITIONS(递推/记忆化搜索+数学)
总时间限制: 1000ms 内存限制: 65536kB

描述
A sequence of positive integers is Palindromic if it reads the same forward and backward. For example:
23 11 15 1 37 37 1 15 11 23
1 1 2 3 4 7 7 10 7 7 4 3 2 1 1
A Palindromic sequence is Unimodal Palindromic if the values do not decrease up to the middle value and then (since the sequence is palindromic) do not increase from the middle to the end For example, the first example sequence above is NOT Unimodal Palindromic while the second example is.
A Unimodal Palindromic sequence is a Unimodal Palindromic Decomposition of an integer N, if the sum of the integers in the sequence is N. For example, all of the Unimodal Palindromic Decompositions of the first few integers are given below:
1: (1)
2: (2), (1 1)
3: (3), (1 1 1)
4: (4), (1 2 1), (2 2), (1 1 1 1)
5: (5), (1 3 1), (1 1 1 1 1)
6: (6), (1 4 1), (2 2 2), (1 1 2 1 1), (3 3),
(1 2 2 1), ( 1 1 1 1 1 1)
7: (7), (1 5 1), (2 3 2), (1 1 3 1 1), (1 1 1 1 1 1 1)
8: (8), (1 6 1), (2 4 2), (1 1 4 1 1), (1 2 2 2 1),
(1 1 1 2 1 1 1), ( 4 4), (1 3 3 1), (2 2 2 2),
(1 1 2 2 1 1), (1 1 1 1 1 1 1 1)

Write a program, which computes the number of Unimodal Palindromic Decompositions of an integer.

输入
Input consists of a sequence of positive integers, one per line ending with a 0 (zero) indicating the end.

输出
For each input value except the last, the output is a line containing the input value followed by a space, then the number of Unimodal Palindromic Decompositions of the input value. See the example on the next page.

样例输入
2
3
4
5
6
7
8
10
23
24
131
213
92
0

样例输出
2 2
3 2
4 4
5 3
6 7
7 5
8 11
10 17
23 104
24 199
131 5010688
213 1055852590
92 331143

提示
N < 250

来源
Greater New York 2002

这是一个数学题,用递推实现,题意是已知数列之和n,求不严格中间高两边低的回文数列个数。
首先,回文数分两类,一类是偶数项的,一类是奇数项的,这就需要关于n分类讨论了,n为奇数是项数必须奇数,n为偶数时候两者皆可,枚举回文数中间一项/两项。发现最后都转化为一个问题,求已知和n与最大值max,把n分为每一项不超过最大值max的数列分法种数f(n,max),注意我们只考虑回文数一边以简化问题。
而f(n,max)可以记忆化搜索/递推实现,注意到按数值等于max的项的有无可以分类为两项之和即可实现递推。
而本机上调试一下发现n<250保证了不需要高精度,只需要long long int。这里要注意有些ACM竞赛考试要求int64而有些要求long long int,另外,这个数学题还是不需要高精度的,还是很良心的…所以要苦练高精度,以加快数学题解题速度。

Accepted 404kB 0ms 659 B G++ 10分钟前

#include<stdio.h>

int n;
long long int F[251][251];
long long int sum=0;

long long int f(int n,int max)
{
    if (max==0 || n<0)
        return 0;
    if (n==0 || n==1)
        return 1;
    if (F[n][max])
        return F[n][max];
    F[n][max]=f(n-max,max)+f(n,max-1);
    return F[n][max];
}

int main()
{
    /*test
    for (int i=1;i<=5;i++)
        for (int j=1;j<=i;j++)
            printf("%d %d:%lld\n",i,j,f(i,j));
    */
    while (scanf("%d",&n)&&n)
    {
        if (n&1)
        {
            sum=1;
            for (int i=1;i<n;i+=2)
                sum+=f((n-i)>>1,i);
        }
        else
        {
            sum=2;
            for (int i=2;i<n;i+=2)
                sum+=f((n-i)>>1,i);
            for (int i=1;i<(n>>1);i++)
                sum+=f((n>>1)-i,i);
        }
        printf("%d %lld\n",n,sum);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值