poj 1080 Human Gene Functions(dp)

poj 1080 Human Gene Functions(dp)
总时间限制: 1000ms 内存限制: 65536kB

描述
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.
这里写图片描述
For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT–TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT–TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.

输入
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

输出
The output should print the similarity of each test case, one per line.

样例输入

2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA

样例输出

14
21

来源
Taejon 2001


这是一个比较简单的动态规划题目,设 f[i][j] 为第一个序列前i位于第二个序列前j位的相似度,则dp状态转移方程式为

f[i][j]=max{f[i1][j1]+sim(s1[i],s2[j]),f[i][j1]+sim( ,s2[j]),f[i1][j]+sim(s1[i], )}
但是本题的边界条件不好处理,一开始数组从0开始使用,无异于作茧自缚,WA。所以后来改成从1开始使用就对了,留下维度的一列一行0给空串用,简化了代码。说明边界条件很容易出错,所以为了提高代码正确性,边界条件代码书写务必深思熟虑,反复推敲。
另外注意,下代码中TEST模式下取值恰好退化为最长公共子串问题。


Accepted    256kB   0ms 1544 B  G++
#define TEST
#undef TEST

#define MAX_N 100

#include<stdio.h>
#include<string.h>

#ifdef TEST
const int sim[5][5]={{1},{0,1}
            ,{0,0,1},{0,0,0,1},{0,0,0,0,1}};
#endif

#ifndef TEST
const int sim[5][5]={{5,-1,-2,-1,-3},{-1,5,-3,-2,-4}
            ,{-2,-3,5,-2,-2},{-1,-2,-2,5,-1},{-3,-4,-2,-1,0}};
#endif

const char name[5]={'A','C','G','T',' '};

int cases;
int a1[MAX_N+1],a2[MAX_N+1],l1,l2;
char ch;
int f[MAX_N+1][MAX_N+1];

inline int Max(int a,int b)
{
    return a>b?a:b; 
}

void read()
{
    scanf("%d ",&l1);
    for (int i=1;i<=l1;i++)
    {
        scanf("%c",&ch);
        for (int t=0;t<4;t++)
            if (name[t]==ch)
            {
                a1[i]=t;
                break;
            }
    }   
    scanf("\n");
    scanf("%d ",&l2);
    for (int i=1;i<=l2;i++)
    {
        scanf("%c",&ch);
        for (int t=0;t<4;t++)
            if (name[t]==ch)
            {
                a2[i]=t;
                break; 
            }
    }
    scanf("\n");
    #ifdef TEST
    for (int i=1;i<=l1;i++)
        printf("%d",a1[i]);
    printf(" ");
    for (int i=1;i<=l2;i++)
        printf("%d",a2[i]);
    printf("\n");
    #endif
    return;
}

int main()
{
    scanf("%d\n",&cases);
    while (cases--)
    {
        read();
        f[0][0]=0;
        for (int i=1;i<=l1;i++)
            f[i][0]=f[i-1][0]+sim[a1[i]][4];
        for (int i=1;i<=l2;i++)
            f[0][i]=f[0][i-1]+sim[a2[i]][4]; 
        for (int i=1;i<=l1;i++)
            for (int j=1;j<=l2;j++)
            {
                f[i][j]=f[i-1][j-1]+sim[a1[i]][a2[j]];
                f[i][j]=Max(f[i][j],f[i][j-1]+sim[4][a2[j]]);
                f[i][j]=Max(f[i][j],f[i-1][j]+sim[4][a1[i]]);
            }
        #ifdef TEST
        for (int i=0;i<=l1;i++) 
            for (int j=0;j<=l2;j++)
                printf("%2d%c",f[i][j],(j==l2)?'\n':' '); 
        #endif
        printf("%d\n",f[l1][l2]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值