HDU Walk (概率DP)

HDU Walk (概率DP):http://acm.hdu.edu.cn/showproblem.php?pid=5001

题面描述:

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 996    Accepted Submission(s): 634
Special Judge


Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

Sample Input
  
  
2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

Sample Output
  
  
0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037


题目大意:

在一个n给节点,m条边的无向图中,以每个顶点为起点的概率相等,求经过d步之后,不经过该点的概率为多少。

题目解析:

不经过这个节点的概率等于去掉该节点的图中走了d步到其他顶点的和。

特殊的枚举方式,对于每个i,因为不让他到达这个点i,所以不达到点i的概率就是到达其他顶点的概率和,不求该点即可。


代码实现:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>

using namespace std;
#define maxn 55
#define maxstep 10005
vector<int> V[maxn];
double dp[maxstep][maxn];

int main()
{
    int T;
    int n,m,d;
    scanf("%d",&T);
    while(T--)
    {
        int a,b;
        scanf("%d%d%d",&n,&m,&d);
        for( int i=1; i<=n; i++)
        {
            V[i].clear();
        }
        for( int i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            V[a].push_back(b);
            V[b].push_back(a);
        }
        for(int i=1; i<=n; i++)
        {
            dp[0][i]=1.0/n;
        }
        for(int i=1; i<=n; i++)
        {
            //memset(dp,0,sizeof(dp));
            for(int j=1; j<=d; j++)
            {
                for(int k=1; k<=n; k++)
                {
                    if(k==i)
                        continue;
                    dp[j][k]=0;
                    for(int q=0; q<V[k].size(); q++)
                    {
                        if(V[k][q]==i) continue;
                        else dp[j][k]+=dp[j-1][V[k][q]]*(1.0/V[k].size());
                    }
                }
            }
            double ans=0;
            for(int j=1; j<=n; j++)
            {
                if(j==i)
                    continue;
                else ans+=dp[d][j];
            }
                printf("%.10lf\n",ans);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值