hdu5858 Hard problem (计算几何):http://acm.split.hdu.edu.cn/showproblem.php?pid=5858
题目描述:
Hard problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 264 Accepted Submission(s): 204
Problem Description
cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?
Give you the side length of the square L, you need to calculate the shaded area in the picture.
The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.
Give you the side length of the square L, you need to calculate the shaded area in the picture.
The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.
Input
The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).
Output
For each test case, print one line, the shade area in the picture. The answer is round to two digit.
Sample Input
1 1
Sample Output
0.29
Author
BUPT
Source
题目大意:求阴影部分面积
题目分析:
巧妙的做辅助线,加加减减得到阴影部分的面积。
代码实现:
#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
const double pi=2*acos(0.0);
double GetArea(double a,double b,double c)
{
double p=(a+b+c)/2;
return sqrt(p*(p-a)*(p-b)*(p-c));
}
int main()
{
int T,L;
double aerfa,beta,sinbeta,ssjx,saob,sacb;
scanf("%d",&T);
while(T--)
{
aerfa=beta=sinbeta=ssjx=saob=sacb=0.0;
scanf("%d",&L);
aerfa=acos(5.0*sqrt(2.0)/8.0);
//cout<<"aerfa="<<aerfa/pi*180<<endl;
sinbeta=2.0*sin(aerfa);
beta=asin(sinbeta);
//cout<<"beta="<<beta/pi*180<<endl;
double a=1.0*L;
double b=1.0*L/2;
double c=1.0*sqrt(2.0)*L/2.0;
ssjx=2*GetArea(a,b,c);
saob=beta*L*L/4.0;
sacb=aerfa*L*L*1.0;
double s=saob+ssjx-sacb;
printf("%.2lf\n",2*s);
//cout<<asin(0.5)<<endl;
}
return 0;
}