算法技巧-空间换时间-队列复原

小瓜现在让1到n这n个整数排成一列,但是他只告诉你每个整数的后面那个数是什么(最后一个整数的后面那个数是0),请你帮忙复原这个队列。

输入第一行一个整数n(n<=100000),表示有n个整数。
接下来n行,每行两个数i,j,表示排在整数i后面的那个数是j。输出n行,每行一个整数,表示完整的队列。
输入样例4
1 3
2 4
3 2
4 0
输出样例
1
3
2
4

首先正常思路,从后往前找,先找0,依次往前

import java.util.ArrayList;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  Scanner sc = new Scanner(System.in);
  int n = sc.nextInt();
  int[] l = new int[n+1];
  for (int i = 0; i < n; i++) {
   int s =sc.nextInt();
   int ss =sc.nextInt();
   l[ss]=s;
  }
  ArrayList<Integer> z = new ArrayList<Integer>();
  int temp = 0;
  while (z.size()<n) {
   z.add(l[temp]);
   temp=l[temp];
  }
  for (int i = z.size()-1; i >= 0; i--) {
   System.out.println(z.get(i));
  }
 }
}

但是我们可以看到。n的大小是小于十万的,如果每寻找一个数就遍历依次全部数则需要大量的时间,肯定会超时!

然后

import java.util.ArrayList;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  Scanner sc = new Scanner(System.in);
  int n = sc.nextInt();
  int[] l = new int[n+1];
  for (int i = 0; i < n; i++) {
   int s =sc.nextInt();
   int ss =sc.nextInt();
   l[ss]=s;
  }
  ArrayList<Integer> z = new ArrayList<Integer>();
  int temp = 0;
  while (z.size()<n) {
   z.add(l[temp]);
   temp=l[temp];
  }
  for (int i = z.size()-1; i >= 0; i--) {
   System.out.println(z.get(i));
  }
 }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

PROBIE_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值