POJ 2393 Yogurt factory(贪心)

总时间限制: 1000ms 内存限制: 65536kB

描述

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.
Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.
Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.

输入

  • Line 1: Two space-separated integers, N and S.

  • Lines 2…N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

输出

  • Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

样例输入

4 5
88 200
89 400
97 300
91 500

样例输出

126900

提示

OUTPUT DETAILS:
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

一开始的代码是这样的,复杂度为O(n^2)

#include <cstring>
#include <iostream>
#include <queue>
#include <math.h>
#include <vector>
#include <algorithm>
#include <map>

#define MAX_N 1010
#define MAX_M 10010
using namespace std;


int main()
{
    int n, s;
    int Y[MAX_M] = {0}, C[MAX_M] = {0};
    long long total = 0;
    long long tmpmin = 0x3f3f3f;
    while (scanf("%d%d", &n, &s) != EOF) {
        memset(Y, 0, sizeof(Y));
        memset(C, 0, sizeof(C));
        total = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &C[i], &Y[i]);
        }
        
        for (int i = n - 1; i >= 0; i--) {
            tmpmin = 1ll * C[i] * Y[i];
            for (int j = 0; j < i; j++) {
                long long curval = 1ll * C[j] * Y[i] + 1ll * (i-j) * s * Y[i];
                if (curval < tmpmin) {
                    tmpmin = curval;
                }
            }
            total += tmpmin;
        }
        printf("%lld\n", total);
    }
    
    
    return 0;
}

后来看到有其他的做法,复杂度只有O(n),

#include <cstring>
#include <iostream>
#include <queue>
#include <math.h>
#include <vector>
#include <algorithm>
#include <map>

#define MAX_N 1010
#define MAX_M 10010
using namespace std;


int main()
{
    int n, s, y, c, m;
    
    long long total = 0;
    while (scanf("%d%d", &n, &s) != EOF) {
        total = 0;
        m = 0x3f3f3f;
        while (n--) {
            scanf("%d%d", &c, &y);
            m = min(m+s, c);
            total += 1ll * m * y;
        }
        
        printf("%lld\n", total);
    }
    
    
    return 0;
}

区别就在于如何遍历所有的日期,我的做法是从后面开始遍历,对于每一天,再从第一天一直找到这一天期间所有的价格,找到一个最小的加上,这样复杂度很高。第二种方法使用m=min(m+s,c)通过将单价c与前一日单价与保存单价之间的比较来得到最后的结果,效率更高。

不过一定要注意的是,对于中间计算结果一定要乘上1ll,就是1后面加一个longlong转换类型,不然会疯狂WA。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值