二分——4 Values whose Sum is 0

								4 Values whose Sum is 0

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output
For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output
5

Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
const int maxn = 4010;
int n;
int a[maxn],b[maxn],c[maxn],d[maxn],cd[maxn*maxn],ab[maxn*maxn];
int find(int i){
	int j;
	int cnt = 0;
	int l = 0;
	int r = n*n-1;
	while(l<=r){
		int mid = (l+r)>>1;
		if(cd[mid] == -ab[i]){
			for(j = mid-1;j>=0;j--){
				if(cd[j]==cd[mid]){
					cnt++;
				}
				else{
					break;
				}
			}
			for(j = mid + 1;j<=n*n-1;j++){
				if(cd[j]==cd[mid]){
					cnt++;
				}
				else{
					break;
				}
			}
			cnt++;
			return cnt;
			break;
		}
		else if(cd[mid] > -ab[i]){
			r = mid - 1;
		}
		else{
			l = mid+1;
		}
	}
	return 0;
}
int main(){
	int t,i,j,cnt,left,right,mid,x;
	scanf("%d",&n);
	for(i = 0;i<n;i++){
		scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
	}
	for(i = 0;i<n;i++){
		for(j = 0;j<n;j++){
			cd[i*n+j] = c[i] + d[j];
			ab[i*n+j] = a[i] + b[j];
		}
	}
	sort(cd,cd+n*n);
	cnt = 0;
	for(i = 0;i<n*n;i++){
		cnt+=find(i);
	}
	printf("%d\n",cnt);
} 

分为ab和cd 2个和数组然后再枚举二分

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值