poj 2785 二分问题 4 Values whose Sum is 0

题意:

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

思路:4个4000的数组,挨个判肯定超时,所以两两一组,2*1.6e7的时间复杂度不会超,因为要四个数相加的和为0,只需要到另外两个数组内找相反数个数即可,由于可能存在相等的数,所以,用lower_bound和upper_bound的差,直接得出相等的数的数量,。很暴力了,自己写二分也可以,不过可能得多注意等于号是否存在的细节

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int maxn=1e6+10;
int n,T,m;
int a[4005],b[4005],c[4005],d[4005],x,y,ans;
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
    }
    vector<int>v,vv;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
    {
        v.push_back(a[i]+b[j]);
        vv.push_back(c[i]+d[j]);

    }
    sort(v.begin(),v.end());
    sort(vv.begin(),vv.end());

    for(int i=0;i<n*n;i++)
    {
        x=lower_bound(vv.begin(),vv.end(),-v[i])-vv.begin();
        y=upper_bound(vv.begin(),vv.end(),-v[i])-vv.begin();
        ans+=y-x;
    }
    cout<<ans<<endl;
    return 0;
}
/*

*/

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值