[数学]HDU1060Leftmost Digit

Problm Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input
2
3
4
Sample Output
2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

N N = 1 0 N × l g N N^N = 10^{N \times lgN} NN=10N×lgN

#include <vector>
#include <cmath>
#include <iostream>
using namespace std;
int main()
{
    int t, n;
    double x, y;
    cin >> t;
    while(t--)
    {
        cin >> n;
        x = n*log10(n);
        y = (long long)x;
        x = x - y;	//去掉大的系数,结果上的体现就是没了后面那一堆零
        cout << int(pow(10.0,x)) << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值