C - Coprime Sequence

Do you know what is called ``Coprime Sequence''? That is a sequence consists of  n npositive integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
Input
The first line of the input contains an integer  T(1T10) T(1≤T≤10), denoting the number of test cases. 
In each test case, there is an integer  n(3n100000) n(3≤n≤100000) in the first line, denoting the number of integers in the sequence. 
Then the following line consists of  n n integers  a1,a2,...,an(1ai109) a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.
Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8
Sample Output
1
2

2

这道题刚开始我就没有思路,看了一下别人的代码,原来还要用到前缀和后缀。思路如下:

依次遍历每个数,算出这堆数的左边最大公约数,然后求出这堆数右边的最大公约数,然后求出他们的共同的最大公约数,遍历每个最大公约数即为所求。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int N=100005;
int GCD(int x,int y)
{
   if(x==0)
        return y;
    else
        return GCD(y%x,x);
  
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,a[N],ar[N],al[N],MAX=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
          scanf("%d",&a[i]);
          if(i==1)
             al[i]=a[i];
          else
            al[i]=GCD(al[i-1],a[i]);
        }
        for(int i=n;i>0;i--)
        {
            if(i==n)
                ar[i]=a[i];
            else
                ar[i]=GCD(ar[i+1],a[i]);
        }
        for(int i=1;i<=n;i++)
        {
            if(i==1)
                MAX=max(MAX,ar[2]);
            if(i==n)
                MAX=max(MAX,al[n-1]);
            else
                MAX=max(MAX,GCD(al[i-1],ar[i+1]));
        }
        printf("%d\n",MAX);
    }
    return 0;
}
    
    















































  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值