2017 CCPC-WFinal&&HDOJ6025 Coprime Sequence(前缀后缀GCD问题)

Coprime Sequence

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 131072/131072 K(Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0

Problem Description

Do you know what is called``Coprime Sequence''? That is a sequence consists ofn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
“Coprime Sequence'' is easy to find because of its restriction. But we can tryto maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

 

 

Input

The first line of the inputcontains an integerT(1≤T≤10) , denoting the number of test cases.
In each test case, there is an integer
n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of
n integersa1,a2,...,an(1≤ai≤109) , denoting the elements in the sequence.

 

 

Output

For each test case, print asingle line containing a single integer, denoting the maximum GCD.

 

 

Sample Input

3

3

1 1 1

5

2 2 2 3 2

4

1 2 4 8

 

 

Sample Output

1

2

2


题意:

给出一系列数,它们的最大公约数为1 ,现在你需要在这些数中删掉任意一个数使剩下的书的最大公约数最大

思路:

依次遍历每个数,算出这个数左边的一堆数的最大公约数x1,再算出这个数右边的一堆数的最大公约数x2,gcd(x1,x2)即为删去当前数后剩下的数的最大公约数。遍历每个数得到的最大gcd即为所求。

而每个数左边的gcd和右边的gcd可以用O(n)的时间复杂度预处理,遍历每个数是跟前面并列的O(n)复杂度,故可线性解决。


#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<=(b);++i)
#define ll long long
const int maxn = 100005;
const int mod = 1e9+7;
const int INF = 0x3f3f3f3f;
const double eps = 1e-6;
#define rush() int T;scanf("%d",&T);while(T--)
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}
int a[maxn];
int l[maxn];
int r[maxn];
int main()
{
    int n;
    rush()
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        l[0]=a[0];
        r[n-1]=a[n-1];
        for(int i=1;i<n;i++)         //求前缀GCD    
        {
            l[i]=gcd(l[i-1],a[i]);
        }
        for(int i=n-2;i>=0;i--)      //求后缀GCD
        {
            r[i]=gcd(r[i+1],a[i]);
        }
        int ans=max(l[n-2],r[1]);
        for(int i=1;i<n-1;i++)       //遍历求最大值
        {
            ans=max(ans,gcd(l[i-1],r[i+1]));
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值