链表


  
  

Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值;  第二行依次输入M个有序的整数;  第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

#include "iostream"
#include"cstdio"
#include"cstring"
#include"cstdlib"
using namespace std;
struct node
{
    int num;
    node *next;
}*head1,*head2;
int n,m;
int main()
{
    scanf("%d%d",&n,&m);
    head1=new node;
    head1->next=NULL;
    head2=new node;
    head2->next=NULL;
    node *q;
    q=head1;
    for(int i=0;i<n;i++)
    {
        node *p=new node;
        p->next=NULL;
        scanf("%d",&p->num);
        q->next=p;
        q=p;

    }
    q=head2;
     for(int i=0;i<m;i++)
    {
        node *p=new node;
        p->next=NULL;
        scanf("%d",&p->num);
        q->next=p;
        q=p;

    }
    q=head1->next;
    node *p=head2->next;
    node *x=head1;
    node *y=p;
    while(p!=NULL&&q!=NULL)
    {
        if(q->num>p->num)
        {
            y=p->next;
            p->next=q;
            x->next=p;
            x=p;
            p=y;
        }
        else
        {
            x=q;
            q=q->next;
        }
    }
   if(p==NULL)
    {
        x->next=q;
    }
    else if(q==NULL)
    {
        x->next=p;
    }
    q=head1->next;
   for(int i=0;i<(n+m-1);i++)
       {
          printf("%d ",q->num);
          q=q->next;
       }
       printf("%d\n",q->num);
    return 0;
}

  
  

Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;  第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input

6
33 6 22 9 44 5

Sample Output

5 6 9 22 33 44
#include "iostream"
#include"cstdio"
#include"cstring"
#include"cstdlib"
using namespace std;
struct node
{
    int num;
    node *next;
}*head1,*head2;
int n;
int main()
{
    scanf("%d",&n);
    head1=new node;
    head1->next=NULL;
    head2=new node;
    head2->next=NULL;
    node *q;
    q=head1;
    for(int i=0;i<n;i++)
    {
        node *p=new node;
        p->next=NULL;
        scanf("%d",&p->num);
        q->next=p;
        q=p;
    }
    node *p;
    node *m=head1;
    q=head1->next;
     node*r;
     node *x,*y;
   while(q->next!=NULL)
   {
      r =q;
      p=q;
      x=m;
      y=x;
    while(p!=NULL)
      {
          if(r->num>p->num)
          {
              y=x;
              r=p;
          }
          x=p;
          p=p->next;
      }
      y->next=r->next;
      m->next=r;
      if(r!=q)
      r->next=q;
      m=r;
      q=m->next;
   }
   q=head1->next;
   for(int i=0;i<n-1;i++)
   {
       printf("%d ",q->num);
       q=q->next;
   }
  printf("%d\n",q->num);
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值